summaryrefslogtreecommitdiff
path: root/sys-cluster/hpl/hpl-2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-cluster/hpl/hpl-2.3.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-cluster/hpl/hpl-2.3.ebuild')
-rw-r--r--sys-cluster/hpl/hpl-2.3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-cluster/hpl/hpl-2.3.ebuild b/sys-cluster/hpl/hpl-2.3.ebuild
new file mode 100644
index 000000000000..6ed3d0fbd20d
--- /dev/null
+++ b/sys-cluster/hpl/hpl-2.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Portable Implementation of the Linpack Benchmark for Distributed-Memory Clusters"
+HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
+SRC_URI="http://www.netlib.org/benchmark/hpl/hpl-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="HPL"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ virtual/mpi"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3-respect-AR.patch"
+)
+
+src_prepare() {
+ default
+
+ # Needed for the AR patch
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ doman man/man3/*.3
+ dodoc testing/ptest/HPL.dat
+
+ if use doc; then
+ docinto html
+ dodoc -r www/*
+ fi
+}
+
+pkg_postinst() {
+ einfo "Remember to copy (+ extract) ${EROOT}/usr/share/${PF}/HPL.dat.bzip2 to your working directory"
+ einfo "before running xhpl. Typically one may run hpl by executing:"
+ einfo "\"mpiexec -np 4 ${EROOT}/usr/bin/xhpl\""
+ einfo "where -np specifies the number of processes."
+}