summaryrefslogtreecommitdiff
path: root/sys-cluster/fake/fake-1.1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /sys-cluster/fake/fake-1.1.10.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'sys-cluster/fake/fake-1.1.10.ebuild')
-rw-r--r--sys-cluster/fake/fake-1.1.10.ebuild35
1 files changed, 14 insertions, 21 deletions
diff --git a/sys-cluster/fake/fake-1.1.10.ebuild b/sys-cluster/fake/fake-1.1.10.ebuild
index 8d3037b8fbff..3f960e577b00 100644
--- a/sys-cluster/fake/fake-1.1.10.ebuild
+++ b/sys-cluster/fake/fake-1.1.10.ebuild
@@ -1,38 +1,31 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils
-
-DESCRIPTION="Fake has been designed to switch in backup servers on a LAN"
+DESCRIPTION="Switch in backup servers on a LAN"
SRC_URI="http://www.vergenet.net/linux/${PN}/download/${PV}/${P}.tar.gz"
HOMEPAGE="http://www.vergenet.net/linux/fake/"
SLOT="0"
KEYWORDS="~amd64 x86"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/fix-ldflags.patch"
-}
+PATCHES=(
+ "${FILESDIR}/fix-ldflags.patch"
+)
-src_compile(){
- make patch || die "patching failed"
- emake || die "make failed"
+src_prepare() {
+ default
+ emake patch
}
src_install(){
emake \
- ROOT_DIR="${D}" \
- MAN8_DIR="${D}/usr/share/man/man8" \
- DOC_DIR="${D}/usr/share/doc/${P}" \
- install || die "install failed"
+ ROOT_DIR="${ED}" \
+ MAN8_DIR="${ED}/usr/share/man/man8" \
+ DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ install
dodoc AUTHORS ChangeLog README docs/*
}