summaryrefslogtreecommitdiff
path: root/sys-cluster/fake/fake-1.1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/fake/fake-1.1.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/fake/fake-1.1.10.ebuild')
-rw-r--r--sys-cluster/fake/fake-1.1.10.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-cluster/fake/fake-1.1.10.ebuild b/sys-cluster/fake/fake-1.1.10.ebuild
new file mode 100644
index 000000000000..d6247089d87c
--- /dev/null
+++ b/sys-cluster/fake/fake-1.1.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Fake has been designed to switch in backup servers on a LAN"
+SRC_URI="http://www.vergenet.net/linux/${PN}/download/${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.vergenet.net/linux/fake/"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/fix-ldflags.patch"
+}
+
+src_compile(){
+ make patch || die "patching failed"
+ emake || die "make failed"
+}
+
+src_install(){
+ emake \
+ ROOT_DIR="${D}" \
+ MAN8_DIR="${D}/usr/share/man/man8" \
+ DOC_DIR="${D}/usr/share/doc/${P}" \
+ install || die "install failed"
+ dodoc AUTHORS ChangeLog README docs/*
+}