summaryrefslogtreecommitdiff
path: root/sys-cluster/crmsh/crmsh-4.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /sys-cluster/crmsh/crmsh-4.2.1.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'sys-cluster/crmsh/crmsh-4.2.1.ebuild')
-rw-r--r--sys-cluster/crmsh/crmsh-4.2.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/crmsh-4.2.1.ebuild b/sys-cluster/crmsh/crmsh-4.2.1.ebuild
new file mode 100644
index 000000000000..312f01a1ed1b
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+AUTOTOOLS_AUTORECONF=true
+KEYWORDS=""
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-3
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit eutils python-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+src_configure() {
+ ./autogen.sh || die
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+}