summaryrefslogtreecommitdiff
path: root/sys-cluster/charmdebug/charmdebug-6.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/charmdebug/charmdebug-6.2.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/charmdebug/charmdebug-6.2.0-r1.ebuild')
-rw-r--r--sys-cluster/charmdebug/charmdebug-6.2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-cluster/charmdebug/charmdebug-6.2.0-r1.ebuild b/sys-cluster/charmdebug/charmdebug-6.2.0-r1.ebuild
new file mode 100644
index 000000000000..117b686bf762
--- /dev/null
+++ b/sys-cluster/charmdebug/charmdebug-6.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit java-pkg-2
+
+DESCRIPTION="A debugger for Charm++ applications"
+HOMEPAGE="http://charm.cs.uiuc.edu/"
+SRC_URI="http://charm.cs.illinois.edu/distrib/binaries/charmdebug/charmdebug_${PV}.tar.gz"
+
+S="${WORKDIR}/${PN}"
+
+LICENSE="charm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ >=virtual/jre-1.6
+ sys-cluster/charm[charmdebug,-smp]"
+
+src_install() {
+ java-pkg_newjar ${PN}.jar
+ java-pkg_dolauncher ${PN} \
+ --main charm/debug/ParDebug \
+ --jar ${PN}.jar \
+ --java_args -ms100000000 -mx512000000
+}