summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 02:44:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 02:44:06 +0100
commitf019a919bf109460ee009a5f9210b99d0467db97 (patch)
tree5e62ee11b837b7b408bb93bf2f01eb74f7b8a73f /sys-cluster/ceph/files
parent6a9905e269a1104c93dceb41e2627a8568642946 (diff)
gentoo auto-resync : 23:08:2022 - 02:44:06
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch22
-rw-r--r--sys-cluster/ceph/files/ceph-16.2.10-gcc12.patch45
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch29
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.1-python310.patch23
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch33
5 files changed, 71 insertions, 81 deletions
diff --git a/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch b/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch
index 3b38c1708733..3319f3989ff9 100644
--- a/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch
+++ b/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch
@@ -1,25 +1,3 @@
-From 4c13a798dcf2e783afd7558bf3541dc025de854a Mon Sep 17 00:00:00 2001
-From: Nathan Cutler <ncutler@suse.com>
-Date: Tue, 27 Jul 2021 15:27:58 +0200
-Subject: [PATCH] compression/snappy: use uint32_t to be compatible with 1.1.9
-
-The snappy project made the following change in snappy.h between version 1.1.8
-and 1.1.9:
-
-< bool GetUncompressedLength(Source* source, uint32_t* result);
----
-> bool GetUncompressedLength(Source* source, uint32* result);
-
-This causes Ceph to FTBFS with snappy 1.1.9.
-
-Thanks to Chris Denice for bringing this to our attention via Redmine.
-
-Fixes: https://tracker.ceph.com/issues/50934
-Signed-off-by: Nathan Cutler <ncutler@suse.com>
----
- src/compressor/snappy/SnappyCompressor.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
diff --git a/src/compressor/snappy/SnappyCompressor.h b/src/compressor/snappy/SnappyCompressor.h
index 25393f8dc1ff4..93206c4007bed 100644
--- a/src/compressor/snappy/SnappyCompressor.h
diff --git a/sys-cluster/ceph/files/ceph-16.2.10-gcc12.patch b/sys-cluster/ceph/files/ceph-16.2.10-gcc12.patch
new file mode 100644
index 000000000000..79bc5d41f410
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-16.2.10-gcc12.patch
@@ -0,0 +1,45 @@
+diff --git a/src/include/buffer.h b/src/include/buffer.h
+index 7c8f90e9fb5d3..71cb01935000b 100644
+--- a/src/include/buffer.h
++++ b/src/include/buffer.h
+@@ -41,6 +41,7 @@
+ #include <iosfwd>
+ #include <iomanip>
+ #include <list>
++#include <memory>
+ #include <vector>
+ #include <string>
+ #if __cplusplus >= 201703L
+
+diff --git a/src/rgw/rgw_string.h b/src/rgw/rgw_string.h
+index 257daa9c1fe6e..90e64f98a2587 100644
+--- a/src/rgw/rgw_string.h
++++ b/src/rgw/rgw_string.h
+@@ -8,6 +8,8 @@
+ #include <stdlib.h>
+ #include <limits.h>
+ #include <string_view>
++#include <string>
++#include <stdexcept>
+
+ #include <boost/container/small_vector.hpp>
+
+
+diff --git a/src/test/encoding.cc b/src/test/encoding.cc
+index 6d252fae18b71..f18901cbd27d9 100644
+--- a/src/test/encoding.cc
++++ b/src/test/encoding.cc
+@@ -334,11 +334,11 @@ void lame_decoder(int which) {
+ }
+
+ TEST(EncodingException, Macros) {
+- for (unsigned i = 0; i < sizeof(expected_what)/sizeof(expected_what[0]); i++) {
++ for (unsigned i = 0; i < std::size(expected_what); i++) {
+ try {
+ lame_decoder(i);
+ } catch (const exception& e) {
+- ASSERT_EQ(string(expected_what[i]), string(e.what()));
++ ASSERT_NE(string(e.what()).find(expected_what[i]), string::npos);
+ }
+ }
+ }
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch b/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch
index f80edddd8de7..e9177cc02764 100644
--- a/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch
+++ b/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch
@@ -1,32 +1,3 @@
-From 78edb6a91788133334ceeeda0c95529df5f40da8 Mon Sep 17 00:00:00 2001
-From: "Kaleb S. KEITHLEY" <kkeithle@redhat.com>
-Date: Mon, 14 Feb 2022 07:42:08 -0500
-Subject: [PATCH] rgw: cmake configure error on fedora-37/rawhide
-
-see
-https://kojipkgs.fedoraproject.org//work/tasks/6624/82706624/build.log,
-excerpted below
-
-...
-CMake Error: The inter-target dependency graph contains the following
-strongly connected component (cycle): "rgw_common" of type
-STATIC_LIBRARY depends on "dbstore" (weak) depends on "sqlite_db" (weak)
-"dbstore" of type SHARED_LIBRARY depends on "rgw_common" (weak) depends
-on "sqlite_db" (weak) "sqlite_db" of type SHARED_LIBRARY depends on
-"rgw_common" (weak) depends on "dbstore" (weak) At least one of these
-targets is not a STATIC_LIBRARY. Cyclic dependencies are allowed only
-among static libraries. CMake Generate step failed. Build files cannot
-be regenerated correctly.
-...
-
-https://tracker.ceph.com/issues/54266
-
-Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
----
- src/rgw/store/dbstore/CMakeLists.txt | 2 +-
- src/rgw/store/dbstore/sqlite/CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
diff --git a/src/rgw/store/dbstore/CMakeLists.txt b/src/rgw/store/dbstore/CMakeLists.txt
index 143ede3c094c9..18e032b73f54f 100644
--- a/src/rgw/store/dbstore/CMakeLists.txt
diff --git a/sys-cluster/ceph/files/ceph-17.2.1-python310.patch b/sys-cluster/ceph/files/ceph-17.2.1-python310.patch
index 767cd2922a26..959e98a8067a 100644
--- a/sys-cluster/ceph/files/ceph-17.2.1-python310.patch
+++ b/sys-cluster/ceph/files/ceph-17.2.1-python310.patch
@@ -1,26 +1,3 @@
-From 389054888f2aa782f73564125ec7a1ef0212d536 Mon Sep 17 00:00:00 2001
-From: Pete Zaitcev <zaitcev@redhat.com>
-Date: Tue, 14 Dec 2021 23:04:34 -0600
-Subject: [PATCH] mgr: Define PY_SSIZE_T_CLEAN ahead of every Python.h
-
-Building on Fedora 35 with Python 3.10 makes vstart to loop
-forever, throwing the following message:
-
- Error EINVAL: SystemError: PY_SSIZE_T_CLEAN macro must be
- defined for '#' formats
-
-I followed the hint in the following document:
- https://docs.python.org/3/c-api/intro.html
-
-It says "recommended" to always define PY_SSIZE_T_CLEAN,
-but as you can see it is actually required in our case.
-
-Fixes: https://tracker.ceph.com/issues/53441
-Signed-off-by: Pete Zaitcev <zaitcev@redhat.com>
----
- src/mgr/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
index 55147af4fc6ba..8f39e41ac0694 100644
--- a/src/mgr/CMakeLists.txt
diff --git a/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch b/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch
index e5e77b4116f6..356da385fedb 100644
--- a/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch
+++ b/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch
@@ -1,12 +1,31 @@
diff --git a/src/include/buffer.h b/src/include/buffer.h
-index 0c89367dd3b..98fcd7c3e08 100644
+index 7c8f90e9fb5d3..71cb01935000b 100644
--- a/src/include/buffer.h
+++ b/src/include/buffer.h
-@@ -62,6 +62,7 @@
- #endif
-
- #include "inline_memory.h"
+@@ -41,6 +41,7 @@
+ #include <iosfwd>
+ #include <iomanip>
+ #include <list>
+#include <memory>
+ #include <vector>
+ #include <string>
+ #if __cplusplus >= 201703L
+
+diff --git a/src/test/encoding.cc b/src/test/encoding.cc
+index 6d252fae18b71..f18901cbd27d9 100644
+--- a/src/test/encoding.cc
++++ b/src/test/encoding.cc
+@@ -334,11 +334,11 @@ void lame_decoder(int which) {
+ }
- #define CEPH_BUFFER_API
-
+ TEST(EncodingException, Macros) {
+- for (unsigned i = 0; i < sizeof(expected_what)/sizeof(expected_what[0]); i++) {
++ for (unsigned i = 0; i < std::size(expected_what); i++) {
+ try {
+ lame_decoder(i);
+ } catch (const exception& e) {
+- ASSERT_EQ(string(expected_what[i]), string(e.what()));
++ ASSERT_NE(string(e.what()).find(expected_what[i]), string::npos);
+ }
+ }
+ }