summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /sys-cluster/ceph/files
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.13-no-virtualenvs.patch (renamed from sys-cluster/ceph/files/ceph-16.2.0-no-virtualenvs.patch)21
1 files changed, 10 insertions, 11 deletions
diff --git a/sys-cluster/ceph/files/ceph-16.2.0-no-virtualenvs.patch b/sys-cluster/ceph/files/ceph-15.2.13-no-virtualenvs.patch
index d8acd4355b59..665bb8914264 100644
--- a/sys-cluster/ceph/files/ceph-16.2.0-no-virtualenvs.patch
+++ b/sys-cluster/ceph/files/ceph-15.2.13-no-virtualenvs.patch
@@ -1,8 +1,8 @@
diff --git a/cmake/modules/AddCephTest.cmake b/cmake/modules/AddCephTest.cmake
-index 2c8fdb0b93..07d52b3d67 100644
+index c9ee8c1b8f..09f75543da 100644
--- a/cmake/modules/AddCephTest.cmake
+++ b/cmake/modules/AddCephTest.cmake
-@@ -70,14 +70,6 @@ function(add_tox_test name)
+@@ -68,14 +68,6 @@ function(add_tox_test name)
endif()
string(REPLACE ";" "," tox_envs "${tox_envs}")
find_package(Python3 QUIET REQUIRED)
@@ -45,7 +45,7 @@ index 4224499c47..9a6c87595b 100644
DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume)
diff --git a/src/pybind/mgr/dashboard/CMakeLists.txt b/src/pybind/mgr/dashboard/CMakeLists.txt
-index 59c28a33f6..7f63e2adf4 100644
+index 92e4cdc538..3153c93c45 100644
--- a/src/pybind/mgr/dashboard/CMakeLists.txt
+++ b/src/pybind/mgr/dashboard/CMakeLists.txt
@@ -5,9 +5,6 @@ function(add_npm_command)
@@ -58,17 +58,16 @@ index 59c28a33f6..7f63e2adf4 100644
string(REPLACE " " ";" command "${command}")
add_custom_command(
OUTPUT "${NC_OUTPUT}"
-@@ -51,11 +48,8 @@ else(WITH_SYSTEM_NPM)
- set(node_mirror_opt "--mirror=$ENV{NODE_MIRROR}")
- endif()
+@@ -29,10 +26,8 @@ else()
+ set(nodeenv NODEENV)
+
add_custom_command(
- OUTPUT "${mgr-dashboard-nodeenv-dir}/bin/npm"
- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv ${node_mirror_opt} -p --node=12.18.2
-- COMMAND mkdir ${mgr-dashboard-nodeenv-dir}/.npm
-+ OUTPUT "/bin/npm"
-+ COMMAND /bin/nodeenv ${node_mirror_opt} -p --node=12.18.2
+- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv --verbose -p --node=10.18.1
++ OUTPUT "npm"
++ COMMAND nodeenv --verbose -p --node=10.18.1
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
COMMENT "dashboard nodeenv is being installed"
- )
+ )