summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-09 21:49:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-09 21:49:23 +0100
commitb8cc45d2d4557cadf73e3411149ffb57ebd8c09b (patch)
tree36e9e50b71907f13105d2d76cda896f2097f8201 /sys-cluster/ceph/files
parent60010a4cd6d7c12aaa62f00b5e8a158ed24efba6 (diff)
gentoo auto-resync : 09:06:2023 - 21:49:23
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.5-gcc13.patch37
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.5-link-boost-context.patch10
2 files changed, 0 insertions, 47 deletions
diff --git a/sys-cluster/ceph/files/ceph-17.2.5-gcc13.patch b/sys-cluster/ceph/files/ceph-17.2.5-gcc13.patch
deleted file mode 100644
index c23badcc5e09..000000000000
--- a/sys-cluster/ceph/files/ceph-17.2.5-gcc13.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://bugs.gentoo.org/878531
-https://github.com/ceph/ceph/pull/48661
-
-From 74794f9d6f5c6671438085bdba730b504901a7c0 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Fri, 28 Oct 2022 16:47:38 +0100
-Subject: [PATCH] common: fix build with GCC 13 (missing <cstdint> include)
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Needed for uint8_t. Only worked by chance before (see
-https://www.gnu.org/software/gcc/gcc-13/porting_to.html).
-
-```
-FAILED: src/CMakeFiles/common-objs.dir/mds/FSMapUser.cc.o
-/usr/bin/x86_64-pc-linux-gnu-g++ -DBOOST_ASIO_DISABLE_THREAD_KEYWORD_EXTENSION -DHAVE_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -D_REENTRANT -D_THREAD_SAFE -D__CEPH__ -D__STDC_FORMAT_MACROS -D__linux__ -I/var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5_build/src/include -I/var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src -isystem /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5_build/include -isystem /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/xxHash -isystem /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/rapidjson/include -O2 -march=native -pipe -fPIC -U_FORTIFY_SOURCE -Wall -fno-strict-aliasing -fsigned-char -Wtype-limits -Wignored-qualifiers -Wpointer-arith -Werror=format-security -Winit-self -Wno-unknown-pragmas -Wnon-virtual-dtor -Wno-ignored-qualifiers -ftemplate-depth-1024 -Wpessimizing-move -Wredundant-move -Wstrict-null-sentinel -Woverloaded-virtual -fno-new-ttp-matching -fstack-protector-strong -fdiagnostics-color=auto -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free -std=c++17 -MD -MT src/CMakeFiles/common-objs.dir/mds/FSMapUser.cc.o -MF src/CMakeFiles/common-objs.dir/mds/FSMapUser.cc.o.d -o src/CMakeFiles/common-objs.dir/mds/FSMapUser.cc.o -c /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/mds/FSMapUser.cc
-In file included from /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/log/SubsystemMap.h:12,
- from /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/common/config.h:23,
- from /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/mds/mdstypes.h:13,
- from /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/mds/FSMapUser.h:21,
- from /var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/mds/FSMapUser.cc:1:
-/var/tmp/portage/sys-cluster/ceph-17.2.5/work/ceph-17.2.5/src/common/subsys_types.h:56:23: error: ‘uint8_t’ in namespace ‘std’ does not name a type; did you mean ‘wint_t’?
-```
-
-Bug: https://bugs.gentoo.org/878531
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/src/common/subsys_types.h
-+++ b/src/common/subsys_types.h
-@@ -17,6 +17,7 @@
-
- #include <algorithm>
- #include <array>
-+#include <cstdint>
-
- enum ceph_subsys_id_t {
- ceph_subsys_, // default
diff --git a/sys-cluster/ceph/files/ceph-17.2.5-link-boost-context.patch b/sys-cluster/ceph/files/ceph-17.2.5-link-boost-context.patch
deleted file mode 100644
index 9ebc70ecce9e..000000000000
--- a/sys-cluster/ceph/files/ceph-17.2.5-link-boost-context.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/src/neorados/CMakeLists.txt b/src/neorados/CMakeLists.txt
-index 3c7aee7c6fe..bda666ea95b 100644
---- a/src/neorados/CMakeLists.txt
-+++ b/src/neorados/CMakeLists.txt
-@@ -41,4 +41,4 @@ target_link_libraries(libneorados PRIVATE
- # install(TARGETS libneorados DESTINATION ${CMAKE_INSTALL_LIBDIR})
- add_library(neorados_cls_fifo STATIC cls/fifo.cc)
- target_link_libraries(neorados_cls_fifo PRIVATE
-- libneorados ceph-common fmt::fmt)
-+ libneorados ceph-common fmt::fmt Boost::context)