summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-06 03:18:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-06 03:18:56 +0000
commita2f130f3156ea1d203e99a781424790176b9b2b5 (patch)
tree10fbba06303ed3b478a8a39114e6b6127ef18dbb /sys-cluster/ceph/files
parent519f4aac6d5896fe0204e6429485f95240c7ff58 (diff)
gentoo auto-resync : 06:02:2023 - 03:18:56
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-gcc12-dout.patch42
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.1-python310.patch12
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch31
3 files changed, 0 insertions, 85 deletions
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-gcc12-dout.patch b/sys-cluster/ceph/files/ceph-17.2.0-gcc12-dout.patch
deleted file mode 100644
index d119bf1bf11d..000000000000
--- a/sys-cluster/ceph/files/ceph-17.2.0-gcc12-dout.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 841806de212226921eeaeb3eea054bda8ccce616 Mon Sep 17 00:00:00 2001
-From: Radoslaw Zarzynski <rzarzyns@redhat.com>
-Date: Wed, 19 Jan 2022 15:24:11 +0000
-Subject: [PATCH 2/2] common: fix FTBFS due to dout & need_dynamic on GCC-12
-
-For details see:
-https://gist.github.com/rzarzynski/d6d2df6888923bef6a3e764f4856853f.
-
-Special thanks to Kaleb Keithley who reported the issue
-and tested the fix!
-
-Fixes: https://tracker.ceph.com/issues/53896
-Signed-off-by: Radoslaw Zarzynski <rzarzyns@redhat.com>
-
-Upstream-Status: Backport [963d756ded40f5adf2efef53893c917bec1845c1]
-Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
----
- src/common/dout.h | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/common/dout.h b/src/common/dout.h
-index c7c08182..42f49915 100644
---- a/src/common/dout.h
-+++ b/src/common/dout.h
-@@ -99,11 +99,12 @@ namespace ceph::dout {
- template<typename T>
- struct dynamic_marker_t {
- T value;
-- operator T() const { return value; }
-+ // constexpr ctor isn't needed as it's an aggregate type
-+ constexpr operator T() const { return value; }
- };
-
- template<typename T>
--dynamic_marker_t<T> need_dynamic(T&& t) {
-+constexpr dynamic_marker_t<T> need_dynamic(T&& t) {
- return dynamic_marker_t<T>{ std::forward<T>(t) };
- }
-
---
-2.36.0
-
diff --git a/sys-cluster/ceph/files/ceph-17.2.1-python310.patch b/sys-cluster/ceph/files/ceph-17.2.1-python310.patch
deleted file mode 100644
index 959e98a8067a..000000000000
--- a/sys-cluster/ceph/files/ceph-17.2.1-python310.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
-index 55147af4fc6ba..8f39e41ac0694 100644
---- a/src/mgr/CMakeLists.txt
-+++ b/src/mgr/CMakeLists.txt
-@@ -33,6 +33,7 @@ if(WITH_MGR)
- mgr_commands.cc
- $<TARGET_OBJECTS:mgr_cap_obj>)
- add_executable(ceph-mgr ${mgr_srcs})
-+ target_compile_definitions(ceph-mgr PRIVATE PY_SSIZE_T_CLEAN)
- if(WITH_LIBCEPHSQLITE)
- target_link_libraries(ceph-mgr cephsqlite SQLite3::SQLite3)
- endif()
diff --git a/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch b/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch
deleted file mode 100644
index 356da385fedb..000000000000
--- a/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/src/include/buffer.h b/src/include/buffer.h
-index 7c8f90e9fb5d3..71cb01935000b 100644
---- a/src/include/buffer.h
-+++ b/src/include/buffer.h
-@@ -41,6 +41,7 @@
- #include <iosfwd>
- #include <iomanip>
- #include <list>
-+#include <memory>
- #include <vector>
- #include <string>
- #if __cplusplus >= 201703L
-
-diff --git a/src/test/encoding.cc b/src/test/encoding.cc
-index 6d252fae18b71..f18901cbd27d9 100644
---- a/src/test/encoding.cc
-+++ b/src/test/encoding.cc
-@@ -334,11 +334,11 @@ void lame_decoder(int which) {
- }
-
- TEST(EncodingException, Macros) {
-- for (unsigned i = 0; i < sizeof(expected_what)/sizeof(expected_what[0]); i++) {
-+ for (unsigned i = 0; i < std::size(expected_what); i++) {
- try {
- lame_decoder(i);
- } catch (const exception& e) {
-- ASSERT_EQ(string(expected_what[i]), string(e.what()));
-+ ASSERT_NE(string(e.what()).find(expected_what[i]), string::npos);
- }
- }
- }