summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 07:36:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 07:36:05 +0100
commit5c0c70d5917e66743293789a6d6fd7d72250eb32 (patch)
treef6738b2393c696bb8b19bd6ff0e52aafadf65101 /sys-cluster/ceph/files
parentc5806fcd6b740ecbd62f4fb2e09d8c8dfa2966fc (diff)
gentoo auto-resync : 13:07:2022 - 07:36:05
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-16.2.9-python310.patch12
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.1-python310.patch35
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-16.2.9-python310.patch b/sys-cluster/ceph/files/ceph-16.2.9-python310.patch
new file mode 100644
index 000000000000..403cfe2f3d1d
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-16.2.9-python310.patch
@@ -0,0 +1,12 @@
+diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
+index 38aad299ccb..8e152e060ea 100644
+--- a/src/mgr/CMakeLists.txt
++++ b/src/mgr/CMakeLists.txt
+@@ -34,6 +34,7 @@ if(WITH_MGR)
+ mgr_commands.cc
+ $<TARGET_OBJECTS:mgr_cap_obj>)
+ add_executable(ceph-mgr ${mgr_srcs})
++ target_compile_definitions(ceph-mgr PRIVATE PY_SSIZE_T_CLEAN)
+ target_link_libraries(ceph-mgr
+ osdc client heap_profiler
+ global-static ceph-common
diff --git a/sys-cluster/ceph/files/ceph-17.2.1-python310.patch b/sys-cluster/ceph/files/ceph-17.2.1-python310.patch
new file mode 100644
index 000000000000..767cd2922a26
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.1-python310.patch
@@ -0,0 +1,35 @@
+From 389054888f2aa782f73564125ec7a1ef0212d536 Mon Sep 17 00:00:00 2001
+From: Pete Zaitcev <zaitcev@redhat.com>
+Date: Tue, 14 Dec 2021 23:04:34 -0600
+Subject: [PATCH] mgr: Define PY_SSIZE_T_CLEAN ahead of every Python.h
+
+Building on Fedora 35 with Python 3.10 makes vstart to loop
+forever, throwing the following message:
+
+ Error EINVAL: SystemError: PY_SSIZE_T_CLEAN macro must be
+ defined for '#' formats
+
+I followed the hint in the following document:
+ https://docs.python.org/3/c-api/intro.html
+
+It says "recommended" to always define PY_SSIZE_T_CLEAN,
+but as you can see it is actually required in our case.
+
+Fixes: https://tracker.ceph.com/issues/53441
+Signed-off-by: Pete Zaitcev <zaitcev@redhat.com>
+---
+ src/mgr/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
+index 55147af4fc6ba..8f39e41ac0694 100644
+--- a/src/mgr/CMakeLists.txt
++++ b/src/mgr/CMakeLists.txt
+@@ -33,6 +33,7 @@ if(WITH_MGR)
+ mgr_commands.cc
+ $<TARGET_OBJECTS:mgr_cap_obj>)
+ add_executable(ceph-mgr ${mgr_srcs})
++ target_compile_definitions(ceph-mgr PRIVATE PY_SSIZE_T_CLEAN)
+ if(WITH_LIBCEPHSQLITE)
+ target_link_libraries(ceph-mgr cephsqlite SQLite3::SQLite3)
+ endif()