summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-cluster/ceph/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.10-build-without-mgr.patch111
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch2
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.4-system-uring.patch66
3 files changed, 178 insertions, 1 deletions
diff --git a/sys-cluster/ceph/files/ceph-14.2.10-build-without-mgr.patch b/sys-cluster/ceph/files/ceph-14.2.10-build-without-mgr.patch
new file mode 100644
index 000000000000..0742945c0184
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-14.2.10-build-without-mgr.patch
@@ -0,0 +1,111 @@
+commit 41c1cee88b38bc43002b232ede42dc157364f61a
+Author: Casey Bodley <cbodley@redhat.com>
+Date: Fri Nov 1 16:04:37 2019 -0400
+
+ cmake: define mgr_cap_obj library when WITH_MGR=OFF
+
+ resolves the cmake error when WITH_MGR=OFF:
+
+ Error evaluating generator expression:
+
+ $<TARGET_OBJECTS:mgr_cap_obj>
+
+ Objects of target "mgr_cap_obj" referenced but no such target exists.
+ Call Stack (most recent call first):
+ src/mon/CMakeLists.txt:34 (add_library)
+
+ Signed-off-by: Casey Bodley <cbodley@redhat.com>
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 275a8ebd17..c2a9d7a669 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -473,9 +473,7 @@ if(WITH_LIBRADOSSTRIPER)
+ add_subdirectory(libradosstriper)
+ endif()
+
+-if(WITH_MGR)
+- add_subdirectory(mgr)
+-endif()
++add_subdirectory(mgr)
+
+ set(librados_config_srcs
+ librados-config.cc)
+diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
+index 79227bcc1d..e69335eb69 100644
+--- a/src/mgr/CMakeLists.txt
++++ b/src/mgr/CMakeLists.txt
+@@ -1,37 +1,39 @@
+ add_library(mgr_cap_obj OBJECT
+ MgrCap.cc)
+
+-set(mgr_srcs
+- ${CMAKE_SOURCE_DIR}/src/ceph_mgr.cc
+- ${CMAKE_SOURCE_DIR}/src/mon/PGMap.cc
+- ActivePyModule.cc
+- ActivePyModules.cc
+- BaseMgrModule.cc
+- BaseMgrStandbyModule.cc
+- ClusterState.cc
+- DaemonHealthMetricCollector.cc
+- DaemonServer.cc
+- DaemonState.cc
+- Gil.cc
+- Mgr.cc
+- MgrStandby.cc
+- OSDPerfMetricTypes.cc
+- OSDPerfMetricCollector.cc
+- PyFormatter.cc
+- PyModule.cc
+- PyModuleRegistry.cc
+- PyModuleRunner.cc
+- PyOSDMap.cc
+- StandbyPyModules.cc
+- mgr_commands.cc
+- $<TARGET_OBJECTS:mgr_cap_obj>)
+-add_executable(ceph-mgr ${mgr_srcs})
+-target_include_directories(ceph-mgr SYSTEM PRIVATE "${PYTHON_INCLUDE_DIRS}")
+-target_link_libraries(ceph-mgr
+- osdc client heap_profiler
+- global-static ceph-common
+- Boost::python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR}
+- ${MGR_PYTHON_LIBRARIES} ${CMAKE_DL_LIBS} ${GSSAPI_LIBRARIES})
+-set_target_properties(ceph-mgr PROPERTIES
+- POSITION_INDEPENDENT_CODE ${EXE_LINKER_USE_PIE})
+-install(TARGETS ceph-mgr DESTINATION bin)
++if(WITH_MGR)
++ set(mgr_srcs
++ ${CMAKE_SOURCE_DIR}/src/ceph_mgr.cc
++ ${CMAKE_SOURCE_DIR}/src/mon/PGMap.cc
++ ActivePyModule.cc
++ ActivePyModules.cc
++ BaseMgrModule.cc
++ BaseMgrStandbyModule.cc
++ ClusterState.cc
++ DaemonHealthMetricCollector.cc
++ DaemonServer.cc
++ DaemonState.cc
++ Gil.cc
++ Mgr.cc
++ MgrStandby.cc
++ OSDPerfMetricTypes.cc
++ OSDPerfMetricCollector.cc
++ PyFormatter.cc
++ PyModule.cc
++ PyModuleRegistry.cc
++ PyModuleRunner.cc
++ PyOSDMap.cc
++ StandbyPyModules.cc
++ mgr_commands.cc
++ $<TARGET_OBJECTS:mgr_cap_obj>)
++ add_executable(ceph-mgr ${mgr_srcs})
++ target_include_directories(ceph-mgr SYSTEM PRIVATE "${PYTHON_INCLUDE_DIRS}")
++ target_link_libraries(ceph-mgr
++ osdc client heap_profiler
++ global-static ceph-common
++ Boost::python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR}
++ ${MGR_PYTHON_LIBRARIES} ${CMAKE_DL_LIBS} ${GSSAPI_LIBRARIES})
++ set_target_properties(ceph-mgr PROPERTIES
++ POSITION_INDEPENDENT_CODE ${EXE_LINKER_USE_PIE})
++ install(TARGETS ceph-mgr DESTINATION bin)
++endif()
diff --git a/sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch b/sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch
index 59663028cfa4..aaa6ee080a33 100644
--- a/sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch
+++ b/sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch
@@ -7,7 +7,7 @@ index c4c24f6a75..b5631e8b84 100644
#define CEPH_COMMON_BIT_STR_H
+#include <cstdint>
-+#include <ostream>
++#include <iosfwd>
#include <functional>
namespace ceph {
diff --git a/sys-cluster/ceph/files/ceph-15.2.4-system-uring.patch b/sys-cluster/ceph/files/ceph-15.2.4-system-uring.patch
new file mode 100644
index 000000000000..64df81bf97b5
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-15.2.4-system-uring.patch
@@ -0,0 +1,66 @@
+diff --git a/src/os/CMakeLists.txt b/src/os/CMakeLists.txt
+index 760244b9b4..7f83923671 100644
+--- a/src/os/CMakeLists.txt
++++ b/src/os/CMakeLists.txt
+@@ -134,27 +134,6 @@ if(WITH_EVENTTRACE)
+ endif()
+
+ if(WITH_LIBURING)
+- include(ExternalProject)
+- if("${CMAKE_GENERATOR}" MATCHES "Make")
+- set(make_cmd "$(MAKE)")
+- else()
+- set(make_cmd "make")
+- endif()
+- ExternalProject_Add(liburing_ext
+- DOWNLOAD_DIR ${CMAKE_BINARY_DIR}/src/
+- GIT_REPOSITORY http://git.kernel.dk/liburing
+- GIT_TAG "4e360f71131918c36774f51688e5c65dea8d43f2"
+- SOURCE_DIR ${CMAKE_BINARY_DIR}/src/liburing
+- CONFIGURE_COMMAND <SOURCE_DIR>/configure
+- BUILD_COMMAND env CC=${CMAKE_C_COMPILER} ${make_cmd} -C src -s
+- BUILD_IN_SOURCE 1
+- INSTALL_COMMAND "")
+- unset(make_cmd)
+- add_library(liburing STATIC IMPORTED GLOBAL)
+- add_dependencies(liburing liburing_ext)
+- set_target_properties(liburing PROPERTIES
+- IMPORTED_LINK_INTERFACE_LANGUAGES "C"
+- IMPORTED_LOCATION "${CMAKE_BINARY_DIR}/src/liburing/src/liburing.a")
+- target_link_libraries(os liburing)
+- target_include_directories(os SYSTEM PRIVATE "${CMAKE_BINARY_DIR}/src/liburing/src/include")
++ pkg_check_modules(LIBURING REQUIRED IMPORTED_TARGET liburing)
++ target_link_libraries(os uring)
+ endif(WITH_LIBURING)
+diff --git a/src/os/bluestore/io_uring.cc b/src/os/bluestore/io_uring.cc
+index 54fa0f9535..4ba83cf172 100644
+--- a/src/os/bluestore/io_uring.cc
++++ b/src/os/bluestore/io_uring.cc
+@@ -7,6 +7,8 @@
+
+ #include "liburing.h"
+ #include <sys/epoll.h>
++#include <unistd.h>
++#include <sys/syscall.h>
+
+ /* Options */
+
+@@ -134,8 +136,7 @@ int ioring_queue_t::init(std::vector<int> &fds)
+ if (ret < 0)
+ return ret;
+
+- ret = io_uring_register(d->io_uring.ring_fd, IORING_REGISTER_FILES,
+- &fds[0], fds.size());
++ ret = io_uring_register_files(&d->io_uring, &fds[0], fds.size());
+ if (ret < 0) {
+ ret = -errno;
+ goto close_ring_fd;
+@@ -214,7 +215,7 @@ bool ioring_queue_t::supported()
+ struct io_uring_params p;
+
+ memset(&p, 0, sizeof(p));
+- int fd = io_uring_setup(16, &p);
++ int fd = syscall(SYS_io_uring_setup, 16, &p);
+ if (fd < 0)
+ return false;
+