summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch')
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch b/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch
new file mode 100644
index 000000000000..8591b0bc7f89
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch
@@ -0,0 +1,26 @@
+diff --git a/src/pybind/CMakeLists.txt b/src/pybind/CMakeLists.txt
+index cd9b27623d2..12688ad32b9 100644
+--- a/src/pybind/CMakeLists.txt
++++ b/src/pybind/CMakeLists.txt
+@@ -36,6 +36,10 @@ execute_process(
+ OUTPUT_VARIABLE "PYTHON3_INSTDIR"
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+
++if(Boost_VERSION VERSION_GREATER_EQUAL 1.74)
++ add_definitions(-DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
++endif()
++
+ install(FILES
+ ceph_argparse.py
+ ceph_daemon.py
+diff --git a/src/test/librados/CMakeLists.txt b/src/test/librados/CMakeLists.txt
+index fc033766cc4..0ba3bc56e98 100644
+--- a/src/test/librados/CMakeLists.txt
++++ b/src/test/librados/CMakeLists.txt
+@@ -1,3 +1,6 @@
++
++add_definitions(-DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
++
+ # radostest
+ add_library(radostest_shared OBJECT test_shared.cc)
+ target_include_directories(radostest_shared PRIVATE