summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/ceph-18.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-13 00:46:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-13 00:46:32 +0000
commit360468f13add58583c7780bcacafb5452a07851d (patch)
treeb9894c277f3edb6e7270436ca2a7000e3575b0a0 /sys-cluster/ceph/ceph-18.2.1.ebuild
parentd71aca7673826d5f5fa93b43c7c8af3c1e023dc6 (diff)
gentoo auto-resync : 13:03:2024 - 00:46:32
Diffstat (limited to 'sys-cluster/ceph/ceph-18.2.1.ebuild')
-rw-r--r--sys-cluster/ceph/ceph-18.2.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-18.2.1.ebuild b/sys-cluster/ceph/ceph-18.2.1.ebuild
index 3e68bf06a4e7..e7b7cdfc84ec 100644
--- a/sys-cluster/ceph/ceph-18.2.1.ebuild
+++ b/sys-cluster/ceph/ceph-18.2.1.ebuild
@@ -414,6 +414,9 @@ src_install() {
python_setup
cmake_src_install
+
+ # the cmake_src_install here installs more egg-info files
+ rm -rf "${D}/$(python_get_sitedir)"/*.egg-info || die
python_optimize
find "${ED}" -name '*.la' -type f -delete || die
@@ -472,6 +475,8 @@ python_install() {
DESTDIR="${ED}" cmake_build src/pybind/install
DESTDIR="${ED}" cmake_build src/cephadm/install
+ rm -rf "${D}/$(python_get_sitedir)"/*.egg-info || die
+
python_optimize
}