summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-01 02:13:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-01 02:13:31 +0100
commitde6c40224da664deb650b25efd11f41044602c76 (patch)
tree705e4bb63436ed72cbca7e1a3aac31778933cff7 /sys-boot
parent54135f54d50ccd967032395ba30074c9d46dab25 (diff)
gentoo auto-resync : 01:04:2024 - 02:13:31
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/Manifest.gzbin5724 -> 5728 bytes
-rw-r--r--sys-boot/vboot-utils/Manifest2
-rw-r--r--sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild9
3 files changed, 8 insertions, 3 deletions
diff --git a/sys-boot/Manifest.gz b/sys-boot/Manifest.gz
index 9b241f4fe25b..a8892d29fd7c 100644
--- a/sys-boot/Manifest.gz
+++ b/sys-boot/Manifest.gz
Binary files differ
diff --git a/sys-boot/vboot-utils/Manifest b/sys-boot/vboot-utils/Manifest
index 3461146e9147..556c64a58f09 100644
--- a/sys-boot/vboot-utils/Manifest
+++ b/sys-boot/vboot-utils/Manifest
@@ -1,4 +1,4 @@
AUX vboot-utils-80-musl-fts.patch 428 BLAKE2B b36b902b045906324e0553f6acba4a760d11289d1d68b38bcfd6c4c6531493f0c778fb2539cb5f19604f8705ceee3dcc2b30caab87f2114ee485345d9b0d7d79 SHA512 59a11a87d9cd4596df749c8dfd188f90818c09a432805cfbb47d02cd13228561af345a336bfd502d205a94ca432cff539ba1ea684542e86f13d6dfdea3db0d41
DIST vboot-utils-80_p20200108.tar.xz 18448212 BLAKE2B f7e375133fb6dc90def1e22c42c7511a3b649c34d067a447f44fb99c1ec37a73d034837c2212e5d6ad368a4f4b011c8cb9eb479e81db4a52b1160cda99382a77 SHA512 077d137d8fe89f35b6f7ec6408b2e9fc7a28765b0987646c1964e6e0c039e359711ab79958c45ee555a0fe810997217225d072a7f1011b1c73c4aefb4e57fcc1
-EBUILD vboot-utils-80_p20200108.ebuild 2724 BLAKE2B c13d1c12ecff0933c90699c84ed9009eb9a001276485fb0c7dbcfa568ff9b61769901ce1aa19fa9b5bf199d27dbe21f2d05468b00a45d6401e1c6d7b9c035ef0 SHA512 13c82d20d5ccff35d5b779aa300d5f0a55b344057a0ee989b106fc476e7992b7ce8fc532e7e6c6abf5a590975e64448bdffb2da1d979fa058767fc6aa7fbcd95
+EBUILD vboot-utils-80_p20200108.ebuild 2823 BLAKE2B 83de907453b83c129e631b1574c1fdfd3300389a428dd6bc1fb24b57b74fa2833285ef4a26b118b5620f6d9520d601f989164c3f284c2e87364e881db416008d SHA512 a18550da1c583d8a08f9810da68372bd5e987c36ed9dce49b3aaab7dfd85a7cfb56106f7bd2bbdb722c14253bed9b31913b66675552b92a0a15577491f3e275c
MISC metadata.xml 564 BLAKE2B ad6937243f239bc16125e600ee1476f4ff67578a0fa6b8816b7627e99b85566527edb78a20aab8e0d04cf0904f493162f9dc4b132f318562b931ac615da62f1a SHA512 0b398ea89054d92429953080f7e2582882525c0f31dc073046b5a71c4d43abb9c559a45f3e22fb3912d301f37fa1884107ddfc4b9132b4fb62b53e4aa4788985
diff --git a/sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild b/sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild
index 67f272d57fa0..e409d0298875 100644
--- a/sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild
+++ b/sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
# Can't use gitiles directly until b/19710536 is fixed.
# This is the name of the latest release branch.
@@ -69,6 +69,7 @@ src_prepare() {
}
_emake() {
+
local arch=$(tc-arch)
emake \
V=1 \
@@ -85,6 +86,10 @@ _emake() {
}
src_compile() {
+ # -Werror=lto-type-mismatch in tests
+ # https://bugs.gentoo.org/880175
+ filter-lto
+
tc-export CC AR CXX PKG_CONFIG
_emake FUZZ_TEST_BINS= TEST_BINS= all
}