summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-28 23:59:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-28 23:59:44 +0100
commit5f0030fd1370c4d03dbb2e0d3086f5e618a33749 (patch)
treed3996b456278fbe1e1528053ddd115c4bac05401 /sys-boot
parent413421048cc2b0df9a218f0ab3cb151846809eb5 (diff)
gentoo auto-resync : 28:04:2024 - 23:59:44
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/Manifest.gzbin5908 -> 5916 bytes
-rw-r--r--sys-boot/mbr/Manifest1
-rw-r--r--sys-boot/mbr/mbr-1.1.11-r2.ebuild33
3 files changed, 34 insertions, 0 deletions
diff --git a/sys-boot/Manifest.gz b/sys-boot/Manifest.gz
index 812b03742d1f..3fd46f11e46e 100644
--- a/sys-boot/Manifest.gz
+++ b/sys-boot/Manifest.gz
Binary files differ
diff --git a/sys-boot/mbr/Manifest b/sys-boot/mbr/Manifest
index 0cc4b8c454a4..2cbc773ee945 100644
--- a/sys-boot/mbr/Manifest
+++ b/sys-boot/mbr/Manifest
@@ -1,3 +1,4 @@
DIST mbr-1.1.11.tar.gz 132060 BLAKE2B 1e7d8267bf4bc4b09a69a61ecf20c82533b4ed879bdaf94c65e361d2e48d7399e41a7c25da757a0f287e33fbb051b6a3bfa038b64f287ddab52b1f1f2529dad0 SHA512 27637b7c37be22ec7947b73684156a38c76dd1d37fad12133dd614ac4b98b578b30a758e6179a7cd62f6044dde2dce19a1e28234aa4bd0d848ef97b44d6cd8f9
EBUILD mbr-1.1.11-r1.ebuild 795 BLAKE2B ae217c60a090332a6684d4d44fdc1971579ebc537f7369a634461022e2876d2d36cc827ed00444f3101e192e984c037e46696fc57613091a78bc04792cf3f720 SHA512 8c4eb134ee5a230936b089a93ddb821e4054fa58d7c688e23ece647596759192be75725b5ac030419dc80bd6fa165f9a4e02376f65fa8de00434e0d945ae2eb7
+EBUILD mbr-1.1.11-r2.ebuild 777 BLAKE2B b1c4adc2d189ccdafd279b5fc45bbe5d9a3131be3065b078d45341a363d71337934cb5baa0d7e97cf6a5c92a819a98258a0966c8b53a39bcadb8dd1865d66459 SHA512 16839ccdfe8760c3eff6d3f64f34df7f0eba9b0a9fc73a5fde1f21d8abf73ee2fc74fd205d807aa89eb7b3d5bfa387c2d9541958e641716581d1c068d22e3ca3
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/sys-boot/mbr/mbr-1.1.11-r2.ebuild b/sys-boot/mbr/mbr-1.1.11-r2.ebuild
new file mode 100644
index 000000000000..82f8be0ffca3
--- /dev/null
+++ b/sys-boot/mbr/mbr-1.1.11-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A replacement master boot record for IBM-PC compatible computers"
+HOMEPAGE="https://www.chiark.greenend.org.uk/~neilt/mbr/"
+SRC_URI="https://www.chiark.greenend.org.uk/~neilt/mbr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sys-devel/bin86"
+BDEPEND="test? ( dev-vcs/rcs )"
+
+src_prepare() {
+ # do not treat warnings as errors
+ sed -i -e "s: -Werror::" {,harness/}Makefile.{in,am} || die
+ default
+}
+
+src_install() {
+ dosbin install-mbr
+ doman install-mbr.8
+ dodoc AUTHORS ChangeLog install-mbr.8 NEWS README TODO
+}
+
+pkg_postinst() {
+ elog "To install the MBR, run /sbin/install-mbr"
+}