summaryrefslogtreecommitdiff
path: root/sys-boot/yaboot-static/yaboot-static-1.3.17-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-boot/yaboot-static/yaboot-static-1.3.17-r2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-boot/yaboot-static/yaboot-static-1.3.17-r2.ebuild')
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.17-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.17-r2.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.17-r2.ebuild
new file mode 100644
index 000000000000..cf88b3abb22c
--- /dev/null
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.17-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe.
+
+EAPI=7
+
+DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
+HOMEPAGE="http://yaboot.ozlabs.org/"
+SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ppc ppc64"
+IUSE="ibm"
+
+DEPEND=""
+RDEPEND="
+ !sys-boot/yaboot
+ sys-apps/ibm-powerpc-utils
+ !ibm? (
+ sys-fs/hfsutils
+ sys-fs/hfsplusutils
+ sys-fs/mac-fdisk
+ )"
+
+S=${WORKDIR}
+
+QA_PRESTRIPPED="
+ /usr/lib/yaboot/yaboot
+ /usr/lib/yaboot/yaboot.chrp
+ /usr/lib/yaboot/addnote
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/new-ofpath-devspec.patch"
+}
+
+src_install() {
+ cp -pPR "${WORKDIR}"/* "${D}" || die
+}