summaryrefslogtreecommitdiff
path: root/sys-boot/woeusb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /sys-boot/woeusb
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'sys-boot/woeusb')
-rw-r--r--sys-boot/woeusb/Manifest2
-rw-r--r--sys-boot/woeusb/woeusb-3.2.12.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-boot/woeusb/Manifest b/sys-boot/woeusb/Manifest
index ddfa3f5664a0..84402cd0dfea 100644
--- a/sys-boot/woeusb/Manifest
+++ b/sys-boot/woeusb/Manifest
@@ -1,3 +1,5 @@
DIST woeusb-3.1.5.tar.gz 399712 BLAKE2B d52b29249af680577299a02cb9a2c1436aef73a0240bff2525c494657c197a2fc0709e0ff6f35eb5d18592145347af284a998deacecff37effd95b75ab13bc9a SHA512 5cf4eb45b126d71bcb376148383faf9713bc06ec4ee3ccc2dfa6528d9fba382bceaae2cdd47f2d8ba775dad1ca8e6258af40fc6362336927894398193600c965
+DIST woeusb-3.2.12.tar.gz 386189 BLAKE2B 53629a185d0b8ff55cb2e60eaa6cb8f9e106d3f5b24f57cf8f777dbf5b9a1e43ed423e53e4710acf9ac5ce3171da7dbfcd40b5b3f297b0db240e7c0f9a687fc0 SHA512 9a4e20003970a3313b080bde9a534fb1724382555281aa510092a3698622dae46f22483ff8968903b5685e00ebfb454718de6db7f3c61c4a2e122c961bfc270f
EBUILD woeusb-3.1.5.ebuild 1036 BLAKE2B 05f973a5a8fd401e9555b5d87cb961a78d0383c8944eabdd35387bb4edb0897eeb184d379647496b6765bcce1d1016cf7d5baa6abba89b6ba1483a91b090b4b8 SHA512 1c8b86ec2a14ff16ad6e82616ff2430b1a364a68ef00b03a330240800ded5e55e1ca0f518523a7c792955846a35b372b396c804c29e1b68c479ec8a49d600671
+EBUILD woeusb-3.2.12.ebuild 1038 BLAKE2B 372b8f269cd8e8e65df8ecce53d8a7838a7baae4da64147e900afe5aeaa7bdc19968aeef120bd17269d48cfdb602b521bbbd4da5dcdc2a503070d270d8c60d85 SHA512 89f65e4f0ef0e5deb11c2aae51d4d4dc55cba9db3751aa34046dd7c6a48691316e1be4a7f3e5644e5202ff4b1bdfd318e44c6ab87700fe4ea07575decd994a7a
MISC metadata.xml 280 BLAKE2B 6e0485a0da47b477f5276aa17735ff1e9b269dbac220b12c615a80a2ad5a7a6f88aa5bcc9bd715355b5687ba50d78bb0cc45d1ef0ba82c52111691b895cffc8e SHA512 af2aa2fda44a73779e31b805313371a2cb6b9ab2846289a73083074fbff99ea1e7da2fefeaccf13b5f11c4c55b6ccb38390f21eab3f4ac1a61e00914ae38fff9
diff --git a/sys-boot/woeusb/woeusb-3.2.12.ebuild b/sys-boot/woeusb/woeusb-3.2.12.ebuild
new file mode 100644
index 000000000000..81c09abcf2ef
--- /dev/null
+++ b/sys-boot/woeusb/woeusb-3.2.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="https://github.com/slacka/WoeUSB"
+SRC_URI="https://github.com/slacka/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ sys-apps/util-linux
+ sys-block/parted
+ sys-fs/dosfstools
+ sys-fs/ntfs3g
+ sys-boot/grub:2[grub_platforms_pc]
+ !minimal? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/WoeUSB-${PV}"
+
+src_prepare() {
+ default
+ find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${PV}/" || die
+ if ! use minimal; then
+ setup-wxwidgets
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ ! use minimal && default
+}
+
+src_compile() {
+ ! use minimal && default
+}
+
+src_test() {
+ ! use minimal && default
+}
+
+src_install() {
+ if use minimal; then
+ dosbin src/woeusb
+ einstalldocs
+ else
+ default
+ fi
+}