summaryrefslogtreecommitdiff
path: root/sys-boot/vboot-utils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-boot/vboot-utils/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-boot/vboot-utils/files')
-rw-r--r--sys-boot/vboot-utils/files/vboot-utils-42_p20150219-cgpt-static.patch36
-rw-r--r--sys-boot/vboot-utils/files/vboot-utils-42_p20150219-sysmacros.patch43
2 files changed, 79 insertions, 0 deletions
diff --git a/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-cgpt-static.patch b/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-cgpt-static.patch
new file mode 100644
index 000000000000..3f53fc7be769
--- /dev/null
+++ b/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-cgpt-static.patch
@@ -0,0 +1,36 @@
+From 9d437e9122019568df7fa2d602f911e6a873d78b Mon Sep 17 00:00:00 2001
+From: Anatol Pomazau <anatol@google.com>
+Date: Thu, 19 Feb 2015 05:11:51 -0800
+Subject: [PATCH] Remove duplicated linker flag
+
+We already set '-static' to LDFLAGS above no need to do it again here.
+
+TEST=build with 'make' and 'make STATIC=1'. Check that 'STATIC=1' adds '-static' linker flag.
+BUG=None
+
+Change-Id: I83e23984753094af203432eb4570930085788398
+Reviewed-on: https://chromium-review.googlesource.com/251151
+Reviewed-by: Mike Frysinger <vapier@chromium.org>
+Reviewed-by: Hung-Te Lin <hungte@chromium.org>
+Reviewed-by: Anatol Pomazau <anatol@google.com>
+Commit-Queue: Anatol Pomazau <anatol@google.com>
+Tested-by: Anatol Pomazau <anatol@google.com>
+---
+ Makefile | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index dfa971c..c0c5f50 100644
+--- a/Makefile
++++ b/Makefile
+@@ -960,7 +960,6 @@ ${CGPT_WRAPPER}: ${CGPT_WRAPPER_OBJS} ${UTILLIB}
+ .PHONY: cgpt
+ cgpt: ${CGPT} ${CGPT_WRAPPER}
+
+-${CGPT}: LDFLAGS += -static
+ ${CGPT}: LDLIBS += -luuid
+
+ ${CGPT}: ${CGPT_OBJS} ${UTILLIB}
+--
+2.3.1
+
diff --git a/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-sysmacros.patch b/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-sysmacros.patch
new file mode 100644
index 000000000000..508f54076766
--- /dev/null
+++ b/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-sysmacros.patch
@@ -0,0 +1,43 @@
+https://chromium-review.googlesource.com/339680
+https://bugs.gentoo.org/580554
+
+From 7fff56afefd4e63dce2366636c084d4c1f1f95d4 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@chromium.org>
+Date: Tue, 19 Apr 2016 13:58:49 -0400
+Subject: [PATCH] include sys/sysmacros.h for major()
+
+The major() func is defined in the sys/sysmacros.h header, so include it
+explicitly for the prototype. Upstream C libs are moving away from having
+sys/types.h include it all the time implicitly.
+
+BUG=None
+TEST=precq passes
+BRANCH=None
+
+Change-Id: I56b84138f08ded2376193403f9c9db22c5f24f71
+---
+
+diff --git a/cgpt/cgpt_wrapper.c b/cgpt/cgpt_wrapper.c
+index dcfaab9..1716cdd 100644
+--- a/cgpt/cgpt_wrapper.c
++++ b/cgpt/cgpt_wrapper.c
+@@ -18,6 +18,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+
+diff --git a/futility/dump_kernel_config_lib.c b/futility/dump_kernel_config_lib.c
+index 4fe990c..abf37ae 100644
+--- a/futility/dump_kernel_config_lib.c
++++ b/futility/dump_kernel_config_lib.c
+@@ -10,6 +10,7 @@
+ #include <string.h>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+