summaryrefslogtreecommitdiff
path: root/sys-boot/systemd-boot/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /sys-boot/systemd-boot/files
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'sys-boot/systemd-boot/files')
-rw-r--r--sys-boot/systemd-boot/files/235-libshared-static.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-boot/systemd-boot/files/235-libshared-static.patch b/sys-boot/systemd-boot/files/235-libshared-static.patch
new file mode 100644
index 000000000000..2a0bf678539b
--- /dev/null
+++ b/sys-boot/systemd-boot/files/235-libshared-static.patch
@@ -0,0 +1,24 @@
+--- a/meson.build
++++ b/meson.build
+@@ -1505,9 +1505,8 @@ if conf.get('ENABLE_EFI') == 1 and conf.get('HAVE_BLKID') == 1
+ exe = executable('bootctl',
+ 'src/boot/bootctl.c',
+ include_directories : includes,
+- link_with : [libshared],
++ link_with : [libshared_static],
+ dependencies : [libblkid],
+- install_rpath : rootlibexecdir,
+ install : true)
+ public_programs += [exe]
+ endif
+diff --git a/src/shared/meson.build b/src/shared/meson.build
+index 883821352..b560e65c9 100644
+--- a/src/shared/meson.build
++++ b/src/shared/meson.build
+@@ -157,5 +157,6 @@ libshared_static = static_library(
+ libshared_name,
+ shared_sources,
+ basic_sources,
++ libsystemd_internal_sources,
+ include_directories : includes,
+ dependencies : libshared_deps)