summaryrefslogtreecommitdiff
path: root/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-30 08:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-30 08:00:51 +0100
commitd5ee59790ee8298b8599b0aa0fa21a98b972a44d (patch)
tree2cc4393cdcfae28879cee110e5975f6e6b798f91 /sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild
parentd855918b46ba8714cf1320fe63b55fd0ed1748a6 (diff)
gentoo auto-resync : 30:06:2024 - 08:00:50
Diffstat (limited to 'sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild')
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild
new file mode 100644
index 000000000000..6d409e02a6d6
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/Kangie/plymouth-openrc-plugin"
+SRC_URI="https://github.com/Kangie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="sys-apps/openrc"
+RDEPEND="${DEPEND}
+ sys-boot/plymouth
+ !sys-apps/systemd"
+
+src_configure() {
+ local emesonargs=(
+ -Ddebug=$(usex debug true false)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "The 'rc_interactive' feature in /etc/rc.conf must be disabled"
+ ewarn "for Plymouth work properly with OpenRC init system."
+ fi
+}