summaryrefslogtreecommitdiff
path: root/sys-boot/mbr-gpt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-boot/mbr-gpt
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-boot/mbr-gpt')
-rw-r--r--sys-boot/mbr-gpt/Manifest5
-rw-r--r--sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild51
-rw-r--r--sys-boot/mbr-gpt/metadata.xml11
3 files changed, 67 insertions, 0 deletions
diff --git a/sys-boot/mbr-gpt/Manifest b/sys-boot/mbr-gpt/Manifest
new file mode 100644
index 000000000000..88c5d5f6e6df
--- /dev/null
+++ b/sys-boot/mbr-gpt/Manifest
@@ -0,0 +1,5 @@
+DIST mbr-gpt_0.0.1.tar.gz 15861 SHA256 c66cc48c6034f1db72ddba187a52f590001a946f87478171b3d362b601b26bc2 SHA512 eaabd84fc749ddee8fa40632ad49e15e894bf35a881fb7c35ba22796c2459a886e9bda601595e58d29567ff26959ae2befe6aec5db397d15e1dc5a292dafe165 WHIRLPOOL 840f2f1d5529fd88c0209eda38a5201d40dbaccc7fd77197f013bd949f899b8f470025c7264fbaed4ef2b9f51b2dd5da97db9e0b0238becc0dca62c988234a2f
+EBUILD mbr-gpt-0.0.1.ebuild 1389 SHA256 3d721113d140efe0e97dc1bf8a64107cdeacdcaf818b9305b4943311d982042e SHA512 9eb0d9967af218ad519ef5224e64e71d3558471d391a441d21dc5a31694c91fd19badcf80ef4097db949cfe544eed675c99229249a15291a014eb89939bf53d2 WHIRLPOOL c5c40936201decba3d966486d6dc9bf0c39e593eaf88f1de03f1df50d6c247ed8089fee2883f35f1d9ae6388deeae3fbec95a0f655815cc9bb8b3bb02320b9f2
+MISC ChangeLog 2926 SHA256 0468cca55f6d7d4a9596e20172de76aeaa8928800f983ca6e41205853730e98c SHA512 bf986593b7068901f111a8b9b81021cbb4201b3ddcab0a592af1afa84710930cae15556c80b802b708ccc76926a8bf4f0b3fdc5f2435944d946b83f973eee134 WHIRLPOOL 7b7c372c26ed8db08c8f4dcd65bf88a0c15fc321efc034a1342eb61a162c0ddd4be50314cd8217044b47ae91dc13b3011fb3c8deb3bcc7860117a445592c154d
+MISC ChangeLog-2015 560 SHA256 a57fcc9d27a368d4fcdf4f76a3bae1a9936de9592d3c72a5bbfe9c380a2be76d SHA512 90787e6f4efb4f80eff889df3c5ada5d7c6d6b47793a877b5358925d80a66bb715fcf08ac9f35913772029a03eacc418feb1cde932a1e0ecdfaba5c9279c5767 WHIRLPOOL c24da827a9a38c32a5e41318d6c502e1fa11dba15e9eee9eda1aa3f7eecc2ea1c01b233ca35b5c5fec8cd469a06ebc0b89d6699087ec5de3d87ccd5d05f53024
+MISC metadata.xml 329 SHA256 4ce73c4d5d41f458fc9039b8da317ba512dcc468f39b9db038e5d6416707179f SHA512 3baca06564c2219ea6175ea39cea467ada4e7bf21a4341fcdc9d5b885ae387f4ca4f93605464b900a2524d64badfae641c5459d0acd0569de1ce848528a46ee4 WHIRLPOOL 19cd1cebebe165ee3cde545b131693f98c677790b8cc07404639880f9c4c83576e5db8080af03f7e7409d0aa4b03b4053de460e6d30ae3ebbc8e645d984e1b56
diff --git a/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild b/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild
new file mode 100644
index 000000000000..cfea4df2fead
--- /dev/null
+++ b/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="An MBR that can handle BIOS-based boot on GPT"
+MY_P="${PN}_${PV}"
+HOMEPAGE="http://aybabtu.com/mbr-gpt/"
+SRC_URI="http://aybabtu.com/mbr-gpt/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+# This should probably NEVER go to stable. It's crazy advanced dangerous magic.
+# It's also pure ASM, so not suitable for elsewhere anyway.
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+# It only depends on binutils/gcc/make, and doesn't link against libc even.
+DEPEND=""
+RDEPEND=""
+
+# It's a mostly an MBR block and it does use the executable stack.
+QA_WX_LOAD="usr/sbin/boot.elf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ emake clean
+
+ # Need to build it 32-bit for the MBR
+ # Btw, no CFLAGS are respected, it's ASM!
+ use amd64 && sed -i -e 's/-Wall/-Wall -m32/g' "${S}"/Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ # get_libdir is not correct here. We want this to go into a 32-bit library
+ # location.
+ insinto /usr/lib/mbr-gpt/
+ doins mbr
+ dosbin boot.elf
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ einfo "See the instructions on the homepage, and make sure you know what"
+ einfo "you are doing before touching this. The mbr file does into your"
+ einfo "MBR, or alternatively you can do a creative reboot utilizing the"
+ einfo "boot.elf binary."
+}
diff --git a/sys-boot/mbr-gpt/metadata.xml b/sys-boot/mbr-gpt/metadata.xml
new file mode 100644
index 000000000000..9590fe15fc00
--- /dev/null
+++ b/sys-boot/mbr-gpt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+</pkgmetadata>