summaryrefslogtreecommitdiff
path: root/sys-boot/lilo/lilo-24.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sys-boot/lilo/lilo-24.2.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sys-boot/lilo/lilo-24.2.ebuild')
-rw-r--r--sys-boot/lilo/lilo-24.2.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/sys-boot/lilo/lilo-24.2.ebuild b/sys-boot/lilo/lilo-24.2.ebuild
index 475926764a55..9ae96a087bd0 100644
--- a/sys-boot/lilo/lilo-24.2.ebuild
+++ b/sys-boot/lilo/lilo-24.2.ebuild
@@ -3,17 +3,17 @@
EAPI="7"
-inherit eutils flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DOLILO_V="0.6"
IUSE="static minimal pxeserial device-mapper"
-DESCRIPTION="Standard Linux boot loader"
-HOMEPAGE="https://alioth.debian.org/projects/lilo/"
+DESCRIPTION="LInux LOader, the original Linux bootloader"
+HOMEPAGE="https://www.joonet.de/lilo/"
DOLILO_TAR="dolilo-${DOLILO_V}.tar.bz2"
SRC_URI="
- http://lilo.alioth.debian.org/ftp/sources/${P}.tar.gz
+ https://www.joonet.de/lilo/ftp/sources/${P}.tar.gz
mirror://gentoo/${DOLILO_TAR}
"
@@ -24,6 +24,10 @@ KEYWORDS="-* amd64 x86"
DEPEND=">=sys-devel/bin86-0.15.5"
RDEPEND="device-mapper? ( >=sys-fs/lvm2-2.02.45 )"
+# Bootloaders should not be using arbitrary CFLAGS without good reason. A bootloader
+# is typically only executed once to boot the system, and it should work the first time.
+QA_FLAGS_IGNORED="/sbin/lilo"
+
src_prepare() {
default
@@ -34,6 +38,7 @@ src_prepare() {
eapply "${FILESDIR}/${PN}-24.2-add-nvme-support.patch"
eapply "${FILESDIR}/${PN}-24.x-fix-gcc-10.patch"
+ eapply "${FILESDIR}/${PN}-24.x-check-for-__GLIBC__.patch"
# Do not strip and have parallel make
# FIXME: images/Makefile does weird stuff
@@ -65,7 +70,6 @@ src_compile() {
}
src_install() {
- keepdir /boot
emake DESTDIR="${D}" install
if use !minimal; then