summaryrefslogtreecommitdiff
path: root/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild')
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
new file mode 100644
index 000000000000..c0237e11495b
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.73[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-apps/dbus"
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+}