summaryrefslogtreecommitdiff
path: root/sys-block/targetcli-fb/targetcli-fb-2.1.49.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /sys-block/targetcli-fb/targetcli-fb-2.1.49.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'sys-block/targetcli-fb/targetcli-fb-2.1.49.ebuild')
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.49.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.49.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.49.ebuild
new file mode 100644
index 000000000000..fb39a7770d3c
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.49.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+MY_PV=$(ver_rs 2 .fb)
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/rtslib-fb[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-apps/dbus"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+}