summaryrefslogtreecommitdiff
path: root/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /sys-block/scsiping/scsiping-0.0.1-r1.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'sys-block/scsiping/scsiping-0.0.1-r1.ebuild')
-rw-r--r--sys-block/scsiping/scsiping-0.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..4879d3b7f737
--- /dev/null
+++ b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="SCSIPing pings a host on the SCSI-chain"
+HOMEPAGE="https://www.vanheusden.com/Linux/"
+SRC_URI="https://www.vanheusden.com/Linux/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/strip scsiping/d' "${S}"/Makefile
+ default
+}
+
+src_compile() {
+ emake DEBUG='' CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dosbin scsiping
+}
+
+pkg_postinst() {
+ ewarn "WARNING: using scsiping on a device with mounted partitions may be hazardous to your system!"
+}