summaryrefslogtreecommitdiff
path: root/sys-block/scsiadd/scsiadd-1.97-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-block/scsiadd/scsiadd-1.97-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-block/scsiadd/scsiadd-1.97-r2.ebuild')
-rw-r--r--sys-block/scsiadd/scsiadd-1.97-r2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-block/scsiadd/scsiadd-1.97-r2.ebuild b/sys-block/scsiadd/scsiadd-1.97-r2.ebuild
new file mode 100644
index 000000000000..112fdbce9ac4
--- /dev/null
+++ b/sys-block/scsiadd/scsiadd-1.97-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Add and remove SCSI devices from your Linux system during runtime"
+HOMEPAGE="https://llg.cubic.org/tools/"
+SRC_URI="https://llg.cubic.org/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="suid"
+
+RDEPEND="suid? ( acct-group/scsi )"
+BDEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # Remove 'strip' command, as portage handles this
+ sed -e "s:^\(.*strip.*\):#\1:g" -i Makefile.in || die
+
+ # Convert docs to UTF-8
+ if [ -x "$(type -p iconv)" ]; then
+ for X in NEWS README; do
+ iconv -f LATIN1 -t UTF8 -o "${X}~" "${X}" \
+ && mv -f "${X}~" "${X}" \
+ || rm -f "${X}~" || die
+ done
+ fi
+}
+
+src_compile() {
+ # Extra safety for suid
+ append-ldflags -Wl,-z,now
+
+ # Use system compiler
+ tc-export CC
+
+ default
+}
+
+src_install() {
+ dosbin scsiadd
+
+ if use suid; then
+ fowners root:scsi /usr/sbin/scsiadd
+ fperms 4710 /usr/sbin/scsiadd
+ fi
+
+ doman scsiadd.8
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ fi
+}