summaryrefslogtreecommitdiff
path: root/sys-block/raid-check/raid-check-20140719-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/raid-check/raid-check-20140719-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/raid-check/raid-check-20140719-r1.ebuild')
-rw-r--r--sys-block/raid-check/raid-check-20140719-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-block/raid-check/raid-check-20140719-r1.ebuild b/sys-block/raid-check/raid-check-20140719-r1.ebuild
new file mode 100644
index 000000000000..5b6d6cd7de2c
--- /dev/null
+++ b/sys-block/raid-check/raid-check-20140719-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Script to do \"scrubbing\" on software RAID systems"
+HOMEPAGE="https://github.com/fukawi2/raid-check"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-path.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" D_BIN=/usr/sbin install
+}