summaryrefslogtreecommitdiff
path: root/sys-block/parted/parted-3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 15:51:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 15:51:39 +0100
commit42e82780761e75f17a5cc96626558a297782f385 (patch)
tree45425190df4e3cbf429fd2b0834f320d51fd6579 /sys-block/parted/parted-3.5.ebuild
parent3d00647fec2600e217d690a64ba45a41f1a2fa0c (diff)
gentoo auto-resync : 10:06:2023 - 15:51:39
Diffstat (limited to 'sys-block/parted/parted-3.5.ebuild')
-rw-r--r--sys-block/parted/parted-3.5.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sys-block/parted/parted-3.5.ebuild b/sys-block/parted/parted-3.5.ebuild
deleted file mode 100644
index a6fac85ad7db..000000000000
--- a/sys-block/parted/parted-3.5.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/bcl.asc
-
-inherit autotools verify-sig
-
-DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
-HOMEPAGE="https://www.gnu.org/software/parted/"
-SRC_URI="
- mirror://gnu/${PN}/${P}.tar.xz
- verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )
-"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+debug device-mapper nls readline"
-
-# util-linux for libuuid
-RDEPEND="
- >=sys-fs/e2fsprogs-1.27
- sys-apps/util-linux
- device-mapper? ( >=sys-fs/lvm2-2.02.45 )
- readline? (
- >=sys-libs/ncurses-5.7-r7:0=
- >=sys-libs/readline-5.2:0=
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- nls? ( >=sys-devel/gettext-0.12.1-r2 )
- verify-sig? ( >=sec-keys/openpgp-keys-bcl-20230315 )
- virtual/pkgconfig
-"
-
-DOCS=(
- AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp}
-)
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
- "${FILESDIR}"/${PN}-3.3-atari.patch
- # https://lists.gnu.org/archive/html/bug-parted/2022-02/msg00000.html
- "${FILESDIR}"/${PN}-3.4-posix-printf.patch
-)
-
-# false positive
-QA_CONFIG_IMPL_DECL_SKIP="MIN"
-
-src_prepare() {
- default
- eautoconf
-
- touch doc/pt_BR/Makefile.in || die
-}
-
-src_configure() {
- local myconf=(
- $(use_enable debug)
- $(use_enable device-mapper)
- $(use_enable nls)
- $(use_with readline)
- --disable-rpath
- --disable-static
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- find "${ED}" -type f -name '*.la' -delete || die
-}