summaryrefslogtreecommitdiff
path: root/sys-block/open-isns/open-isns-0.100.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-block/open-isns/open-isns-0.100.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-block/open-isns/open-isns-0.100.ebuild')
-rw-r--r--sys-block/open-isns/open-isns-0.100.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-block/open-isns/open-isns-0.100.ebuild b/sys-block/open-isns/open-isns-0.100.ebuild
deleted file mode 100644
index fa1351cf05c8..000000000000
--- a/sys-block/open-isns/open-isns-0.100.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="iSNS server and client for Linux"
-HOMEPAGE="https://github.com/open-iscsi/open-isns"
-SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug ssl static"
-
-DEPEND="
- ssl? (
- dev-libs/openssl:0=
- )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.100-respect-AR.patch"
-
- # Upstream patches (can usually be removed with next version bump)
- "${FILESDIR}"/${P}-no_Werror.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
- append-lfs-flags
- local myeconfargs=(
- --without-slp
- $(use_with ssl security)
- $(use_enable !static shared)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- emake DESTDIR="${D}" install_hdrs
- emake DESTDIR="${D}" install_lib
- keepdir /var/lib/${PN/open-}
- if ! use static ; then
- find "${ED}" -type f -name "*.a" -delete || die
- fi
-}