summaryrefslogtreecommitdiff
path: root/sys-block/open-isns/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sys-block/open-isns/files
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sys-block/open-isns/files')
-rw-r--r--sys-block/open-isns/files/open-isns-0.100-no_Werror.patch41
-rw-r--r--sys-block/open-isns/files/open-isns-0.97-musl.patch11
-rw-r--r--sys-block/open-isns/files/open-isns-0.97-ossl-1.1.patch47
3 files changed, 41 insertions, 58 deletions
diff --git a/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch b/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch
new file mode 100644
index 000000000000..2d966dd3a4fd
--- /dev/null
+++ b/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch
@@ -0,0 +1,41 @@
+From 40eb9ce75518817762a0eac4a93016ab817add89 Mon Sep 17 00:00:00 2001
+From: Lee Duncan <lduncan@suse.com>
+Date: Sat, 1 Feb 2020 10:23:04 -0800
+Subject: [PATCH] Fix 586 compile issue and remove -Werror
+
+Using -Werror causes any issue to break the build, whereas
+I'd rather let the build continue and address the issue.
+
+Also, fixed one signed-vs-unsigned compare for time_t, which
+shows up only on 586 (32-bit).
+---
+ configure.ac | 2 +-
+ isnsdd.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e4f3995..d956e58 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,7 +17,7 @@ AC_PATH_PROG(SH, sh)
+ dnl C Compiler features
+ AC_C_INLINE
+ if test "$GCC" = "yes"; then
+- CFLAGS="-Wall -Werror -Wextra $CFLAGS"
++ CFLAGS="-Wall -Wextra $CFLAGS"
+ CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
+ fi
+
+diff --git a/isnsdd.c b/isnsdd.c
+index 58825cc..9cedb9f 100644
+--- a/isnsdd.c
++++ b/isnsdd.c
+@@ -401,7 +401,7 @@ check_portal_registration(__attribute__((unused))void *ptr)
+ continue;
+
+ last_modified = isns_object_last_modified(obj);
+- if (last_modified + 2 * interval > now) {
++ if ((time_t)(last_modified + 2 * interval) > now) {
+ good_portals++;
+ continue;
+ }
diff --git a/sys-block/open-isns/files/open-isns-0.97-musl.patch b/sys-block/open-isns/files/open-isns-0.97-musl.patch
deleted file mode 100644
index 098ade40a213..000000000000
--- a/sys-block/open-isns/files/open-isns-0.97-musl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/libisns/util.h.orig
-+++ ./include/libisns/util.h
-@@ -114,6 +114,6 @@
- # define ntohll(x) __bswap_64(x)
- # endif
- # else
--# include <sys/endian.h>
-+# include <endian.h>
- # define htonll(x) htobe64(x)
- # define ntohll(x) be64toh(x)
- # endif
diff --git a/sys-block/open-isns/files/open-isns-0.97-ossl-1.1.patch b/sys-block/open-isns/files/open-isns-0.97-ossl-1.1.patch
deleted file mode 100644
index ebb641af27d4..000000000000
--- a/sys-block/open-isns/files/open-isns-0.97-ossl-1.1.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 70b11a0f9c4056dc6891c2d5550c28993905f18a Mon Sep 17 00:00:00 2001
-From: eroen <open-isns@occam.eroen.eu>
-Date: Mon, 2 Jan 2017 23:15:08 +0100
-Subject: [PATCH] Disable deprecated initializations for openssl-1.1.0
-
-This fixes several undefined reference errors when linking with
-openssl-1.1.0c.
-
-X-Gentoo-Bug: 604454
-X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=604454
----
- pki.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/pki.c b/pki.c
-index f69ddca..5fdf9f2 100644
---- a/pki.c
-+++ b/pki.c
-@@ -67,7 +67,9 @@ void BN_GENCB_free(BN_GENCB *cb)
- #endif
-
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- static int isns_openssl_init = 0;
-+#endif
-
- static int isns_dsasig_verify(isns_security_t *ctx,
- isns_principal_t *peer,
-@@ -92,6 +94,7 @@ isns_create_dsa_context(void)
- {
- isns_security_t *ctx;
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- if (!isns_openssl_init) {
- ERR_load_crypto_strings();
- OpenSSL_add_all_algorithms();
-@@ -99,6 +102,7 @@ isns_create_dsa_context(void)
- OpenSSL_add_all_digests();
- isns_openssl_init = 1;
- }
-+#endif
-
- ctx = isns_calloc(1, sizeof(*ctx));
-
---
-2.11.0
-