summaryrefslogtreecommitdiff
path: root/sys-block/nwutil/nwutil-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/nwutil/nwutil-1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/nwutil/nwutil-1.4.ebuild')
-rw-r--r--sys-block/nwutil/nwutil-1.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-block/nwutil/nwutil-1.4.ebuild b/sys-block/nwutil/nwutil-1.4.ebuild
new file mode 100644
index 000000000000..7b77c5c4f9bf
--- /dev/null
+++ b/sys-block/nwutil/nwutil-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DEB_VER=3
+DESCRIPTION="Netwinder hardware utilities"
+HOMEPAGE="http://packages.debian.org/stable/base/nwutil"
+SRC_URI="mirror://debian/pool/main/n/nwutil/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/n/nwutil/${PN}_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* arm"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${PN}_${PV}-${DEB_VER}.diff
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-rename-debug.patch
+ epatch "${FILESDIR}"/${P}-temp.patch
+ mv {,nw}debug.c
+ mv {,nw}debug.8
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake main failed"
+ emake -C flashlogo || die "emake flashlogo failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install main failed"
+ make DESTDIR="${D}" install -C flashlogo || die "install flashlogo failed"
+}