summaryrefslogtreecommitdiff
path: root/sys-block/mbuffer/mbuffer-20191016.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sys-block/mbuffer/mbuffer-20191016.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sys-block/mbuffer/mbuffer-20191016.ebuild')
-rw-r--r--sys-block/mbuffer/mbuffer-20191016.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-block/mbuffer/mbuffer-20191016.ebuild b/sys-block/mbuffer/mbuffer-20191016.ebuild
new file mode 100644
index 000000000000..100537bee29c
--- /dev/null
+++ b/sys-block/mbuffer/mbuffer-20191016.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="https://www.maier-komor.de/mbuffer.html"
+SRC_URI="https://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="debug ssl test"
+
+REQUIRED_USE="test? ( ssl )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/openssl:0 )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20180410-sysconfdir.patch"
+)
+
+src_prepare() {
+ ln -s "${DISTDIR}"/${P}.tgz test.tar #258881
+
+ # Enforce MAKEOPTS=-j1 because src_test() spawns multiple listener
+ # using same port and src_install may have problems (with /etc folder)
+ export MAKEOPTS=-j1
+
+ default
+
+ mv configure.in configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ssl md5)
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} || has network-sandbox ${FEATURES}; then
+ ewarn "Some tests may fail with FEATURES=usersandbox or"
+ ewarn "FEATURES=network-sandbox; Skipping tests because"
+ ewarn "test suite would hang forever in such environments!"
+ return 0;
+ fi
+
+ default
+}
+
+pkg_postinst() {
+ if ! has_version "app-arch/mt-st"; then
+ elog ""
+ elog "If you want autoloader support you need to install \"app-arch/mt-st\" in addition!"
+ fi
+}