summaryrefslogtreecommitdiff
path: root/sys-block/flashbench/flashbench-20120606.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 01:35:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 01:35:27 +0000
commit3cba520665a0461aa7b0ada016f4a0df717e37a2 (patch)
tree2a653051c7ea63b16724a5da9d583994530ab97b /sys-block/flashbench/flashbench-20120606.ebuild
parent8c39538f1e5cf37f42c409a6c742f96abef56f3b (diff)
gentoo auto-resync : 25:12:2023 - 01:35:27
Diffstat (limited to 'sys-block/flashbench/flashbench-20120606.ebuild')
-rw-r--r--sys-block/flashbench/flashbench-20120606.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-block/flashbench/flashbench-20120606.ebuild b/sys-block/flashbench/flashbench-20120606.ebuild
index c7f3200b611c..56deca15c711 100644
--- a/sys-block/flashbench/flashbench-20120606.ebuild
+++ b/sys-block/flashbench/flashbench-20120606.ebuild
@@ -1,17 +1,25 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="Tool for benchmarking and classifying flash memory drives"
-HOMEPAGE="http://git.linaro.org/people/arnd.bergmann/flashbench.git"
+HOMEPAGE="https://git.linaro.org/people/arnd.bergmann/flashbench.git"
SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+src_compile(){
+ tc-export CC
+ default
+}
+
src_install() {
dobin "${PN}"
newbin erase "${PN}-erase" # erase is too ambiguous.