summaryrefslogtreecommitdiff
path: root/sys-block/cec/cec-14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
commit1494784ae35c6fa7b6a92a80dea93265fc54ccd0 (patch)
treedbbb1b83e130750c3a55a4287c3a2ec2bbff7af8 /sys-block/cec/cec-14-r1.ebuild
parentee74b33422f15493c315bdacf20da95d5b936d3c (diff)
gentoo auto-resync : 18:06:2023 - 19:48:47
Diffstat (limited to 'sys-block/cec/cec-14-r1.ebuild')
-rw-r--r--sys-block/cec/cec-14-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-block/cec/cec-14-r1.ebuild b/sys-block/cec/cec-14-r1.ebuild
new file mode 100644
index 000000000000..fb689a6f52be
--- /dev/null
+++ b/sys-block/cec/cec-14-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Coraid Ethernet Console client"
+HOMEPAGE="http://aoetools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${PN}-14-including-select.h-and-time.h.patch
+ "${FILESDIR}"/${PN}-14-using-unsigned-int-instead-of-uint.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin ${PN}
+ doman ${PN}.8
+ dodoc ${PN}.txt NEWS README
+}