summaryrefslogtreecommitdiff
path: root/sys-block/buffer/buffer-1.19-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /sys-block/buffer/buffer-1.19-r4.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'sys-block/buffer/buffer-1.19-r4.ebuild')
-rw-r--r--sys-block/buffer/buffer-1.19-r4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-block/buffer/buffer-1.19-r4.ebuild b/sys-block/buffer/buffer-1.19-r4.ebuild
new file mode 100644
index 000000000000..b933ee375e56
--- /dev/null
+++ b/sys-block/buffer/buffer-1.19-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="a tapedrive tool for speeding up reading from and writing to tape"
+HOMEPAGE="http://www.microwerks.net/~hugo/"
+
+DEBIAN_PR=12
+DEBIAN_P="${PN}_${PV}"
+DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PR}.debian.tar.xz"
+# We do NOT rename the Debian .orig.tar.gz file at this point
+# Because Gentoo shipped a very slightly DIFFERENT buffer-1.19.tgz than Debian!
+# Enough to make the debian patchset not apply directly. Debian patchset
+# contains the same changes plus more fixes.
+SRC_URI="
+ mirror://debian/pool/main/b/${PN}/${DEBIAN_P}.orig.tar.gz
+ mirror://debian/pool/main/b/${PN}/${DEBIAN_PATCH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ for f in $(<"${WORKDIR}"/debian/patches/series) ; do
+ p="${WORKDIR}"/debian/patches/${f}.patch
+ ln -sf "${f}" "${p}" || die
+ einfo $p
+ eapply -p1 "${p}" || die
+ done
+ cd "${S}"
+ emake clean
+ eapply_user
+}
+
+src_compile() {
+ append-lfs-flags
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin buffer
+ dodoc README
+ newman buffer.man buffer.1
+}