summaryrefslogtreecommitdiff
path: root/sys-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-14 07:13:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-14 07:13:52 +0000
commitfe1e3bbca60a6b4b9a1889f5252e02c27b459f63 (patch)
tree2ee0c8c664dc7593daf17a1bfac31e1dd4e5c6f5 /sys-auth
parent94eb99943eafb48140b436b347abaaee77209c01 (diff)
gentoo auto-resync : 14:01:2024 - 07:13:52
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-2.0.2.ebuild47
-rw-r--r--sys-auth/AusweisApp2/Manifest2
-rw-r--r--sys-auth/Manifest.gzbin9250 -> 9252 bytes
-rw-r--r--sys-auth/nss-pam-ldapd/Manifest4
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r2.ebuild5
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r3.ebuild7
-rw-r--r--sys-auth/oath-toolkit/Manifest2
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.11.ebuild69
8 files changed, 129 insertions, 7 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-2.0.2.ebuild b/sys-auth/AusweisApp2/AusweisApp2-2.0.2.ebuild
new file mode 100644
index 000000000000..d86746427953
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-2.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-qt/qtshadertools:6
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtbase:6[concurrent,network,widgets]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtscxml:6[qml]
+ dev-qt/qtsvg:6
+ dev-qt/qtwebsockets:6[qml]
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index d29b9104cb7d..2df907fbf905 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1,4 +1,6 @@
DIST AusweisApp2-2.0.1.tar.gz 9123033 BLAKE2B 86f0d9838285bc35a29611e14c4328c584ffeff5c584916960486f9b120ff7472372fdb250a7a014ecfd2e3fdf4992fb827387c6e374427ef0b178f6f455cdf7 SHA512 81ceeab73111cce3f72a89584dedd78436190fca47d6901eb7d9a15775df06ce0dac12ff3cc52c38c82cd316d50ffaae6b2d7a8c85d9fb7e6ead58850b5ea535
+DIST AusweisApp2-2.0.2.tar.gz 9125599 BLAKE2B 3f48007d330be35bebb49f668a01cc765225bfb2ccc9dfa01f32dc1fe3905077a5bcc9c08a8b01fac8df713571b539b358aacbb1e96dad7715fb64d0312a5252 SHA512 9433199b1d1f8f53a0c95b6c1b4f05ed0cf58f6a7afee35618f2cf8a45d2212584bf2bffad4e850e0413cfaa9a3223c3495fad6165581fa3933630eb249aa104
EBUILD AusweisApp2-2.0.1.ebuild 910 BLAKE2B d1aaf65386b5339398d7ed38d86b1ec8cbb332eda37e111282266c537db1ad55a8f3380f90b64f6fdc442b849471039ce874d8aebd415363d0c831f3ca749198 SHA512 4a1b6322614a3f646b65e52c0f66e9cd2bb79debbe9dc32df8e8c5549b6bd9aa4ccc63305d930a8b1457a794aeadcf6ecbb8286b7258c9d5c264fb49e1f591c0
+EBUILD AusweisApp2-2.0.2.ebuild 911 BLAKE2B 5fb0feea2a99816a8426d3ced8847289fa71116ba4456bd0f979d157a6d00fbdbe63745b041f1a5b0bf7f7e2848f7c3d7b410ff05d0917f3089b77b5dd099dfc SHA512 6710189f8e7388b73e27ea70ffeaad233d8d218338cdc8e5efbe280c6d83532a3bdb409d919995031f994a26ccf2c6d1d28568ef82a7cb529fc9cb112667545f
EBUILD AusweisApp2-9999.ebuild 896 BLAKE2B a283585d7f09d304017e9f80f3e081fa96787d702e919aa9f9bcd229078b6d17a9eb3dfeb8782f8011530a6cd8a3ab72be12c88251d4675c1924dea66a77672c SHA512 f361e420657a46e8234517d204548fb69b14bc367be38aa1f85b411bdcd53fdb6dc7a6b3807cf22376f82abc076181965d633b50e4b01a5a7a1032bbf45c0165
MISC metadata.xml 338 BLAKE2B cc2c3169dbe9280f8ab769c2c2c38a691d0af53999169948243cca1200c2a6ef8bb2f97dcc0e8dcbd709f3660fa262bf5279d3acce525baefe91951f91f1eca7 SHA512 db2026e39095afa71c7431290d8032fb6cdf70138beb14ae5cc20f4c5d03a0fa334cd769c14fe1085520b8631947c35c654bbd686ccc2e60a308d19ef6eb9e83
diff --git a/sys-auth/Manifest.gz b/sys-auth/Manifest.gz
index 850c5876cd14..eb0d5758607b 100644
--- a/sys-auth/Manifest.gz
+++ b/sys-auth/Manifest.gz
Binary files differ
diff --git a/sys-auth/nss-pam-ldapd/Manifest b/sys-auth/nss-pam-ldapd/Manifest
index ab28d1d614b8..483f2fdf4b79 100644
--- a/sys-auth/nss-pam-ldapd/Manifest
+++ b/sys-auth/nss-pam-ldapd/Manifest
@@ -10,6 +10,6 @@ AUX nss-pam-ldapd-0.9.12-netdb-defines.patch 861 BLAKE2B a7a8774f31bd9a2a156965e
AUX nss-pam-ldapd-0.9.4-disable-py3-only-linters.patch 403 BLAKE2B 2e17a92b3650ce4e6627be7ddb2f656cd9ab53e49d7e2b11d078dac0d7a00015d88d861bfdc1378eb25c1b9750ed3811023cc95b04ccf9d028ffc5899dc01cd5 SHA512 c8cccb044a641f673f12db9717bda4c0c4d91bd1933342595d8f3f540449459c5cf14263133487195b223670d450873f608e3ce5b6f1ca775ca7fe0180a9f962
AUX pynslcd.init 515 BLAKE2B 711ba152ea9cc52198171e451889ab42a224581bae7e4378846f480063ed9a672fdb38b153d6941364d3d06e325d9feb95f6fd17885b4e6181d99393cb54de0a SHA512 56334d86cc027e538d8a0bf9a8b87308e3ae6e91be608a4a630f21c57cc41b6cb5dc6fb3220fed1ca555dd4da6a5c7c10b2776f9e49a7b71a96ece21fc65fed7
DIST nss-pam-ldapd-0.9.12.tar.gz 791983 BLAKE2B af580d400230db709f7ac09720edd6127b3b26c6987d1e8f6d6535ad8e68fd8cb5cf2a3319e4456fb2af28aba6528f7a5cdc28463ccfee747dbbf6abc35eee87 SHA512 5eca4851a9bcb2779548d193a363a143d6106bfc6463b8d3f0c2d5d7d227ec1e680861383d4813f40b44d1be2ce5f7ed019d838f7f6796e15f96f7411d3bb8f6
-EBUILD nss-pam-ldapd-0.9.12-r2.ebuild 4332 BLAKE2B f13475fccddd44cbb836b9ec6904f4fa73d7005d75c7bacdbbeace490620cc4141d29605e59d795d5c4c65805cc817e860458e05bb8db6bec5ab8d952ea959b1 SHA512 bd17348fc4ab892b1aa44ba09a11b1c424de35aec4fe94921e1b14c2d3abdf855811d4d05f5f349cd78d452ab10e69a0ce2baf64ab0159f2d965a1883a353162
-EBUILD nss-pam-ldapd-0.9.12-r3.ebuild 4487 BLAKE2B 55a8283e61d0c93e8b21622a4b302167f756e03de52deb9e530b8b7c51b4fa297a6505dd5ecf7a48c76eefcc70079f962a21f102a95e7a260531b21d18ae7e52 SHA512 0d1032db5f355306af8348359c62d824acee95b07a3795b216c65585b62d750a028b2e63bd78215542e0d719273d9c19097d9eee8eead4e299548ddcd1563e6f
+EBUILD nss-pam-ldapd-0.9.12-r2.ebuild 4357 BLAKE2B 56044860c62001793fc4bab3b68ade77aae423db633cc331e64d93a7f6923414e747ca123944f890d30aed50b6040f2a506d0cd5784e13308543a5afb4cab0c5 SHA512 a6411a2efa0493eb80848052b6e4e6722e05c5e8b930761cae484a2503cc7064d70a99db58dabcc784a4ef1fd7b4405cd30706ea5ea6bc16a689902c21407acb
+EBUILD nss-pam-ldapd-0.9.12-r3.ebuild 4517 BLAKE2B 488cea6b9598c2044a0541968ef812f8039ca170f3585346d9a4e847987af195dbdc4cf899190e13390a3e61f380e7c82483deb114a84acde599acd0c9cbe714 SHA512 c6c8bbbf60296b04120657f6ef149a9a51ce3996d13a700a5fb2947e1fd5199ec454a751d9a1986b62b9631d78c0e11b12148682222eb78c95f4a01807cc4d09
MISC metadata.xml 1170 BLAKE2B 5c121a0afae864d757fda18c8546e494804c9b9d6a7d6fe2ad485b6a7bb2ed291776063407721222fa765251c9ca4d945740e8a0aa53da670747fb35cf1b8f9e SHA512 ba534679ae3b983a9b143530112f6495a4a4b5b82077095b3cc62965c1cf808c7a2d098410c00bee195112c5e7ff3afe4b368fa9a1662ce22cf48634229df7cf
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r2.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r2.ebuild
index 474304460092..0f8f3074c0d5 100644
--- a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r2.ebuild
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools python-r1 s6 systemd tmpfiles multilib-minimal
DESCRIPTION="NSS module for name lookups using LDAP"
@@ -15,6 +15,7 @@ SLOT="0"
KEYWORDS="amd64 arm ~hppa ~ia64 ~ppc ppc64 ~sparc x86"
IUSE="debug kerberos +pam pynslcd sasl test +utils"
REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
utils? ( ${PYTHON_REQUIRED_USE} )
test? ( ${PYTHON_REQUIRED_USE} pynslcd )
"
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r3.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r3.ebuild
index cd1a50ce5be8..bb818b9c0a9e 100644
--- a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r3.ebuild
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.12-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools python-r1 s6 systemd tmpfiles multilib-minimal
DESCRIPTION="NSS module for name lookups using LDAP"
@@ -12,9 +12,10 @@ SRC_URI="https://arthurdejong.org/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ~ppc64 ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc64 ~sparc x86"
IUSE="debug kerberos +pam pynslcd sasl selinux test +utils"
REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
utils? ( ${PYTHON_REQUIRED_USE} )
test? ( ${PYTHON_REQUIRED_USE} pynslcd )
"
diff --git a/sys-auth/oath-toolkit/Manifest b/sys-auth/oath-toolkit/Manifest
index 3eefbd7e736a..6a970739aa4d 100644
--- a/sys-auth/oath-toolkit/Manifest
+++ b/sys-auth/oath-toolkit/Manifest
@@ -1,8 +1,10 @@
AUX oath-toolkit-2.6.7-new-xmlsec-tests.patch 2925 BLAKE2B c3e2e52ef75f99276b449d0520a1546a8b492d1572c4d293b7b876cb64661086d195f79a420dd763d8aab06e286c46a542a345178218a5f82e43f7ac6cb92079 SHA512 b99f6601ea2d1072b815e2975ebf352a3b20a185d96686b4abb96036c983e256d51e171fbf3af9df1783261bf0051779655ac6838d720956220696c06abde108
DIST oath-toolkit-2.6.10.tar.gz 4710528 BLAKE2B 2fd3c890214089b47bc4eb5759735cc921ed73f9eb9fa52aa8cc9f329b9887a45dbc0118ca077aecebc38660388d1be29a94d8c87917361def86f3a9378f5d40 SHA512 b9a4447350593c206aabf4dce09273194d5ac499c4f2fca4e36ba77480793898e3011655451d9147748b56c2a8611e04640ba2aec5f4e96fcd9e967b93b1c1b7
+DIST oath-toolkit-2.6.11.tar.gz 4699215 BLAKE2B f3fa3ab1818f4f9bbf7c8c88432cd3432fbfb30dfcc660ab85f07e2d3d7e1616fc24579900bc55bbf72fb81b2eac4a6591553968872f07d8b3955ce4e6495afd SHA512 42df879bebccdde3d38558ba735e09db14d0c916b9f0d3a1842e0ecc80614b7d1ee44db39d3097970a2a7108446da6eefd09bdd32dd2fb81d6aed06dc19552fd
DIST oath-toolkit-2.6.7.tar.gz 5625279 BLAKE2B 23f377c51eb633bf01d6085d33c7362cd91b6bed1cf4c2bbf32dc9433849e20c53f6896b16e5056b13f420f6a65a3c593fa1dafd7e184ed9e52666d94a7f75d1 SHA512 50edff75c8366887d69cf4740c4cc3bdfc3e43cbd4910ff40f735bca489f0953d7e5a21130f12782ac7a1f2fb00f0db313aff139085f23daba78a69bc7b2eb12
DIST oath-toolkit-2.6.9.tar.gz 4693524 BLAKE2B 572512311bbfa18d325c7b9b8d88ff85c05241c9a22942bc67edf531ed621e68b031dc4562bd8473ec1b1bfe264c8a4084c1c304ba0d24914acc5b21325b8601 SHA512 6e96b5a926f6e2448661fef267dcf9c99167b7bdfc71e319d2ab7ddc051a7be002043485547ad83744209c25ea0d87f8e28f25cccd6856281321f3d22e3cf160
EBUILD oath-toolkit-2.6.10.ebuild 1449 BLAKE2B 71554e47d40c8deb64e4da1b1153961b278955c3948508b42a999cc877f07aa9149f2b0c98c0efd5d13133b131d28b9f5f938a698492d9b460e119cf331e8ad5 SHA512 6e1be431749f8edf8311a34dcf4cd27a9e58438995febf1e89f94f846ef530293f17f652771da5bed8b08858e75702ad05b1c3382fce5c1312c3a8be58fd19ac
+EBUILD oath-toolkit-2.6.11.ebuild 1449 BLAKE2B 71554e47d40c8deb64e4da1b1153961b278955c3948508b42a999cc877f07aa9149f2b0c98c0efd5d13133b131d28b9f5f938a698492d9b460e119cf331e8ad5 SHA512 6e1be431749f8edf8311a34dcf4cd27a9e58438995febf1e89f94f846ef530293f17f652771da5bed8b08858e75702ad05b1c3382fce5c1312c3a8be58fd19ac
EBUILD oath-toolkit-2.6.7-r2.ebuild 1435 BLAKE2B 6d344b7794665f8516cedd7b9f5f60ec03c479ad407f5cc16a2454729e3a236b2a72f5e535560ea227cfaf142fd667cdbf7c1cef61774b4df37d0b877ac9e65d SHA512 db75ea75dee20fc8640454719075e587e0b26134fb09365be72d450c8c0a79dace7a379961398edfba5a1669e39368fdaa078166d013c0aac3bd501cd164e191
EBUILD oath-toolkit-2.6.9.ebuild 1408 BLAKE2B 6f73316f7e7fdca1ca4329dbc442c4c6524d97da8a6407b43f2b09ac786bab08c1b3bd9b2ae06a3e77cb3b020787bce837250ad8d073eb73ce9fbed3b2da161b SHA512 75b2887889fd9d07303229dfb3054a6fe66ad3d1e2bf578e1abfe44909547c967b8808ab098a823fd1a1f1dd0880196f7012a5b59ede51688bbb8c45bd0a0dc6
MISC metadata.xml 592 BLAKE2B c5428eac278df13bc3cf23e1d5dce5ac4802a262d9f586574035a54af1e0b70547d9ce645636159e3f0cd8942bd77fb4e4f2253ba962d373189ea17f209dc824 SHA512 ed86f998c76cbe3bbcf2e1efa7c91cca0d3872530b6194f8534ff41da407bb8b642c6742fae5a65f2fc216144c977ca33c1b7f414872e5e23c3862b01c256a43
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.11.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.11.ebuild
new file mode 100644
index 000000000000..f6f70d28c0fc
--- /dev/null
+++ b/sys-auth/oath-toolkit/oath-toolkit-2.6.11.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pam
+
+DESCRIPTION="Toolkit for using one-time password authentication with HOTP/TOTP algorithms"
+HOMEPAGE="https://www.nongnu.org/oath-toolkit/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="pam static-libs test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/icu:=
+ dev-libs/libxml2
+ dev-libs/xmlsec:=
+ pam? ( sys-libs/pam )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gtk-doc-am
+ test? ( dev-libs/libxml2 )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ MIN # glibc fp
+ unreachable
+ alignof
+ static_assert
+)
+
+src_configure() {
+ local myeconfargs=(
+ --cache-file="${S}"/config.cache
+ --enable-pskc
+ $(use_enable test xmltest)
+ $(use_enable pam)
+ $(use_with pam pam-dir $(getpam_mod_dir))
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Without keep-going, it will bail out after the first testsuite failure,
+ # skipping the other testsuites. as they are mostly independent, this sucks.
+ emake --keep-going check
+
+ # Avoid errant QA notice for no tests run on these
+ rm -f libpskc/gtk-doc/test-suite.log liboath/gtk-doc/test-suite.log || die
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -type f -delete || die
+
+ if use pam; then
+ newdoc pam_oath/README README.pam
+ fi
+
+ doman pskctool/pskctool.1
+}