summaryrefslogtreecommitdiff
path: root/sys-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
commit2099ff9b640e648be67527e29760263a7c6274e5 (patch)
tree238358af0ba45fd8fcc6cd4679736d6c4f07f851 /sys-auth
parentd198e0ebeee70707545d19ee3beb1de70802cc7c (diff)
gentoo auto-resync : 28:04:2023 - 05:11:40
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/Manifest.gzbin9240 -> 9241 bytes
-rw-r--r--sys-auth/pam_p11/Manifest3
-rw-r--r--sys-auth/pam_p11/files/pam_p11-0.3.1-libressl.patch28
-rw-r--r--sys-auth/pam_p11/pam_p11-0.3.1.ebuild6
4 files changed, 35 insertions, 2 deletions
diff --git a/sys-auth/Manifest.gz b/sys-auth/Manifest.gz
index c6a5192c9a0d..3fea271fc8e8 100644
--- a/sys-auth/Manifest.gz
+++ b/sys-auth/Manifest.gz
Binary files differ
diff --git a/sys-auth/pam_p11/Manifest b/sys-auth/pam_p11/Manifest
index c1b29993ea75..287c976c7280 100644
--- a/sys-auth/pam_p11/Manifest
+++ b/sys-auth/pam_p11/Manifest
@@ -1,3 +1,4 @@
+AUX pam_p11-0.3.1-libressl.patch 1059 BLAKE2B fd586db2ca961421c477a2cb949addfe88f4afeaf9e726956e3ac0daab509fe88882118c789ffb8ee6476c9bd1fb75b6215d7da7ca54f190cd66324307ab76d3 SHA512 44b91a5cb71d640b21b8652183c7add5fb07abd826dc1483396bbaf3ba35d15440d9ff2a2ebe2c40425a272a5fe7b6d58f08fadf35e874939bb361dea3359b02
DIST pam_p11-0.3.1.tar.gz 422940 BLAKE2B b4c6d60a7ee31d808b9e928339f6e8aba3b56655b9f408ff7cd15ff4a397c89c00d00b0bbe70fc0b7bd6c6a246acd9c313c8f5b21a88e1474355c3407ff694f0 SHA512 caaa6882d4c007dfaba5974dc420bc45aa225f705679d170fdc9576aa49cbd24bba6985f14eb2bca97d4fe37aaf6088641add912dfbb93740b7d634f448addcf
-EBUILD pam_p11-0.3.1.ebuild 778 BLAKE2B 6f87bcd1fd02e56258f06a51094dfd54db373c3f31e922c178de53fafef46c0ef789abb37d06e9b0bb0d5ed395cc2774e7fe2ddba285f2cb77b26a8171001d0a SHA512 e313c484855355d57c4665b69a38d6d0eb171861df8695578c61b13dd7ac2cb27dc0ec8120d7594c361929109672e6534625c06f90bf8bc3d8d1b7138eea6193
+EBUILD pam_p11-0.3.1.ebuild 834 BLAKE2B 9d8dc7caa625f0b417f50eb79dc2d9ecac5d11f9a3321a0907b3f22271cf92933cfbf1fcba09646f380020cc0aa822c1505ab6570c98e9994b3514e85b4abfc2 SHA512 1db5c54a5d571f3832f0a31f1decad023ae4f42c00034e8b9e7c7aed5317f8d85f0aa8de643e15fbffbab4d637cc144913b7986d1337b38cb21e5dc85b74112e
MISC metadata.xml 298 BLAKE2B 001ea981512037cadd755c96c7b145ffb8a2c640852f5c3471315edbab111aa241334cef0d8e6d9049d85dc225fa86c027698125828be52e4a21ba962c43f50e SHA512 59a894c6a7c2fec3abf5e341f992846d2b3f0ec6d86ef8456dfa3e7cbf20f07c1c368091085bb5289da626231664fa04f31475353f6c23c1542f0aec6b76f4e5
diff --git a/sys-auth/pam_p11/files/pam_p11-0.3.1-libressl.patch b/sys-auth/pam_p11/files/pam_p11-0.3.1-libressl.patch
new file mode 100644
index 000000000000..e085e06e9006
--- /dev/null
+++ b/sys-auth/pam_p11/files/pam_p11-0.3.1-libressl.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/903001
+https://github.com/OpenSC/pam_p11/pull/26
+https://github.com/OpenSC/pam_p11/commit/cb2f0c318c94e30addfce3b432ed91496a43e411
+
+From b307045a93d042ac9e3871e35f8495e8bb201574 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Tue, 11 Apr 2023 07:29:12 -0700
+Subject: [PATCH] match_openssh: Fix the build for LibreSSL >= 3.0.0
+
+Newer LibreSSL versions no longer need the older OpenSSL APIs.
+---
+ src/match_openssh.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/match_openssh.c b/src/match_openssh.c
+index 89cbd73..fb59308 100644
+--- a/src/match_openssh.c
++++ b/src/match_openssh.c
+@@ -22,7 +22,8 @@
+
+ #define OPENSSH_LINE_MAX 16384 /* from openssh SSH_MAX_PUBKEY_BYTES */
+
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined (LIBRESSL_VERSION_NUMBER)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || \
++ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x3000000L)
+ void RSA_get0_key(const RSA *r,
+ const BIGNUM **n, const BIGNUM **e, const BIGNUM **d)
+ {
diff --git a/sys-auth/pam_p11/pam_p11-0.3.1.ebuild b/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
index 0322e3038be0..4b50c70d2edc 100644
--- a/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
+++ b/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,10 @@ RDEPEND="sys-libs/pam
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-libressl.patch" #903001
+)
+
src_configure() {
# Ugly way to work around deprecated declarations in openssl-3
append-cflags -Wno-error=deprecated-declarations