summaryrefslogtreecommitdiff
path: root/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild')
-rw-r--r--sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild48
1 files changed, 25 insertions, 23 deletions
diff --git a/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild b/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
index 730d8745e2c1..5148727daa45 100644
--- a/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
+++ b/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit autotools-utils user linux-info pam
+inherit linux-info pam
DESCRIPTION="Support for the UPEK/SGS Thomson fingerprint reader, common in Thinkpads"
HOMEPAGE="http://thinkfinger.sourceforge.net/"
@@ -12,13 +12,15 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug pam static-libs"
+IUSE="debug pam"
-RDEPEND="virtual/libusb:0
+DEPEND="
+ virtual/libusb:0
pam? ( sys-libs/pam )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- virtual/pkgconfig"
+RDEPEND="
+ ${DEPEND}
+ acct-group/fingerprint"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PV}-direct_set_config_usb_hello.patch
@@ -29,7 +31,7 @@ PATCHES=(
)
pkg_setup() {
- if use pam ; then
+ if use pam; then
CONFIG_CHECK="~INPUT_UINPUT"
ERROR_CFG="Your kernel needs uinput for the pam module to work"
check_extra_config
@@ -37,43 +39,43 @@ pkg_setup() {
}
src_configure() {
- local myeconfargs=(
+ econf \
+ --disable-static \
$(use_enable pam) \
$(use_enable debug usb-debug) \
- "--with-securedir=$(getpam_mod_dir)"
- )
- autotools-utils_src_configure
+ --with-securedir="$(getpam_mod_dir)"
+
+ rm README.in || die
}
src_install() {
- DOCS=( AUTHORS ChangeLog NEWS README )
- autotools-utils_src_install
+ default
keepdir /etc/pam_thinkfinger
insinto /lib/udev/rules.d
doins "${FILESDIR}"/60-thinkfinger.rules
-}
-pkg_preinst() {
- enewgroup fingerprint
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
fowners root:fingerprint /etc/pam_thinkfinger
fperms 710 /etc/pam_thinkfinger
+
elog "Use tf-tool --acquire to take a finger print"
elog "tf-tool will write the finger print file to /tmp/test.bir"
- elog ""
- if use pam ; then
+ elog
+
+ if use pam; then
elog "To add a fingerprint to PAM, use tf-tool --add-user USERNAME"
- elog ""
+ elog
elog "Add the following to /etc/pam.d/system-auth after pam_env.so"
elog "auth sufficient pam_thinkfinger.so"
- elog ""
+ elog
elog "Your system-auth should look similar to:"
elog "auth required pam_env.so"
elog "auth sufficient pam_thinkfinger.so"
elog "auth sufficient pam_unix.so try_first_pass likeauth nullok"
- elog ""
fi
}