summaryrefslogtreecommitdiff
path: root/sys-auth/solo-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sys-auth/solo-python
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sys-auth/solo-python')
-rw-r--r--sys-auth/solo-python/Manifest2
-rw-r--r--sys-auth/solo-python/solo-python-0.0.27.ebuild35
2 files changed, 0 insertions, 37 deletions
diff --git a/sys-auth/solo-python/Manifest b/sys-auth/solo-python/Manifest
index 8bb3473aca0e..f043d1158ed0 100644
--- a/sys-auth/solo-python/Manifest
+++ b/sys-auth/solo-python/Manifest
@@ -1,5 +1,3 @@
-DIST solo-python-0.0.27.tar.gz 35657 BLAKE2B 747d8849ad4bdda7c0e4b079dce2d7162f07dad4784bb941242dd8ea759cccd763537cec2c7cd9ecf6f467c771729217648b72aa36292622f5fc3adb8a0c280c SHA512 50d564916e07a0c65a843bd2d0328a735ba71eadcfc893b13fac84a3e51822ed2bf80fc3f7662943a5635c6cd6b3ded8ba5b5a9ac2282c9f9bcdfe9de191e445
DIST solo-python-0.0.30.tar.gz 34932 BLAKE2B 6787d9c6e102cd2cb5579be0cb3ffbbe76b3ae90f4fa6891b6a1ca3e76436568a949daa6796fc17c9868d10d5de3b0dd377619936eccb0d436a284a35efa40a9 SHA512 bba63e598ef585ef49e98f3ec2a79911cf8af3fc38c9407bd91b7500dc55bf84f365664e6f80ff0ed3553ce93f5d61ba11c5301e8b36d6000c7a922857adaa5e
-EBUILD solo-python-0.0.27.ebuild 1176 BLAKE2B d1d247c95a6ae62b1f8f1964f303592a2ea7639c48aaa80d6e31d3bfbcb2d3b161ad7856cc93413601ed86d65a962dcdd0a03ddb374b745ef08b047c4f9ddef0 SHA512 f642a785bb585855c0cf93de1a96b5ff129784629215dbea706acc0c21aa98d55255bfd6fbe0126b4eaa64668e28aaec7f0da5478413743c66f56e055d31fbb6
EBUILD solo-python-0.0.30.ebuild 1134 BLAKE2B 1e703ee0c685f70d9b1ab0382d6d7a5e7049298628973e40c7dd63f3fbc8ab5654c11538fcf5cb9cec3424f65368c0418812ebaf9995d5451f53f94006649638 SHA512 d1b429c6f7eada8d5198742c2af4a0e0b5960934a30c2c67cd28b75812849926a4752700e467a0dd8f1679315207319293cf7b194e265921cf3a1fcb6c8be681
MISC metadata.xml 691 BLAKE2B 56d4a4830788efd1222f1e3a9e456b01d43c876856f8ad5063ea9a2a75363fcd66cccc9100af139aadb63b68741493ed89e398c5a38d7a41b676bae187cde15c SHA512 0814323a9067bdfca6730146c21e0c46243eae7b3f68603de5bb3f455f57e47743ea5bce602a897b3f37f27c8981c281d49e04c279295cea74b207d6c0e65945
diff --git a/sys-auth/solo-python/solo-python-0.0.27.ebuild b/sys-auth/solo-python/solo-python-0.0.27.ebuild
deleted file mode 100644
index 2ffa6ee8da58..000000000000
--- a/sys-auth/solo-python/solo-python-0.0.27.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-
-inherit distutils-r1
-
-DESCRIPTION="Python tool and library for SoloKeys"
-HOMEPAGE="https://github.com/solokeys/solo-python"
-SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-RDEPEND=">=dev-python/click-7.0.0[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/ecdsa[${PYTHON_USEDEP}]
- >=dev-python/fido2-0.8.1[${PYTHON_USEDEP}]
- <dev-python/fido2-0.9.0[${PYTHON_USEDEP}]
- dev-python/intelhex[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- dev-python/pyusb[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]"
-
-src_prepare() {
- # For some reason the version file gets omitted by src_install (a bug in pyproject2setuppy?),
- # and in any case there is no advantage to using one once a specific version has been released.
- sed -i -e "s/^__version__ = open(.\+$/__version__ = '${PV}'/" solo/__init__.py || die "Failed to set the version number"
- distutils-r1_src_prepare
-}