summaryrefslogtreecommitdiff
path: root/sys-auth/solo-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sys-auth/solo-python
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sys-auth/solo-python')
-rw-r--r--sys-auth/solo-python/Manifest4
-rw-r--r--sys-auth/solo-python/solo-python-0.0.26.ebuild4
-rw-r--r--sys-auth/solo-python/solo-python-0.0.27.ebuild34
3 files changed, 39 insertions, 3 deletions
diff --git a/sys-auth/solo-python/Manifest b/sys-auth/solo-python/Manifest
index ed75252492b4..8384b8c9004a 100644
--- a/sys-auth/solo-python/Manifest
+++ b/sys-auth/solo-python/Manifest
@@ -1,3 +1,5 @@
DIST solo-python-0.0.26.tar.gz 35251 BLAKE2B 76e515667220a8efdd16e159008eed8232721e0a8a1a1bffbc773cfa832b2f112d8dc229bf69dc4ccbee1d11b41d630a2d91e2383ebd19158d8c46ccf4f355de SHA512 f97da4a4ed3b0e0f4715407b179d8a8c1385076611fe8669cec6b514313d38dd14c6c22434b73e2c72f7456407a6c942b26b72cca7a56969cfbc630ee25aad85
-EBUILD solo-python-0.0.26.ebuild 1134 BLAKE2B 5f3c95b9e520cd4e913f775f1cf266d064cd1f3a5cbc971610449fa6c416c40b7b7b4e37a2e646d65b2de8a9d774277ed3f2b6baf06d1e0a7fe239f2683c0cb8 SHA512 7dc20e360858194051ddf3781ceb731f51d02b6203fd2e7c779a4d3790a9d65ba1d4a8d1470cd1e8a832d9043aaa642b06c112e156f6a5fb00ee24921de77e03
+DIST solo-python-0.0.27.tar.gz 35657 BLAKE2B 747d8849ad4bdda7c0e4b079dce2d7162f07dad4784bb941242dd8ea759cccd763537cec2c7cd9ecf6f467c771729217648b72aa36292622f5fc3adb8a0c280c SHA512 50d564916e07a0c65a843bd2d0328a735ba71eadcfc893b13fac84a3e51822ed2bf80fc3f7662943a5635c6cd6b3ded8ba5b5a9ac2282c9f9bcdfe9de191e445
+EBUILD solo-python-0.0.26.ebuild 1133 BLAKE2B bfe44a9ace058b7cae1592afdb3724246529c4795d2f4e6b1adb0e8a479c6768203ca4537b2e4d8f28829ba1213ebb16c334b23875eed2b41da040077db771eb SHA512 a154b8616f47fb03c1b5432be0a3b31f491ffd9ff23967f0616717558d159f1176077d96e5e149300a7004572ee30406319c66af89fc1b6057ba6f960db1218e
+EBUILD solo-python-0.0.27.ebuild 1134 BLAKE2B 85b5a2b965d6f1a2833259dabb9ea3c3544fa51b4cae81cd1774ced9a6453e3af3a6dc6df5a72c0ca5dd511728a445794795f6cdd658315bdc20ea6969730086 SHA512 4064559b4ca71b9d3c3068125cab35cb1ac15f78be1ad32e29d291cb6c80a0446b13c1a7a2270613cbf5c9d53c39dfd21b10a96a02778038e43e175488b79997
MISC metadata.xml 667 BLAKE2B 7ca73329d8c7713c4c96848d6c5fc23bec99cd45e42266236fe2c5e7d70023bd8d5647da307f0e362863b38393fb9d66c2bb8965763eac3bdf7d5f30a357c7a0 SHA512 ec1899ba5d2082758c79a2abda4e834fbe31358c900507d02801b2a04ea8d37ca2d420a974e16fc8813ffc4f92488f8db5a0d998600c6d28191942592004d031
diff --git a/sys-auth/solo-python/solo-python-0.0.26.ebuild b/sys-auth/solo-python/solo-python-0.0.26.ebuild
index df378e83b42f..e818982ae301 100644
--- a/sys-auth/solo-python/solo-python-0.0.26.ebuild
+++ b/sys-auth/solo-python/solo-python-0.0.26.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0 MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
RDEPEND=">=dev-python/click-7.0.0[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
diff --git a/sys-auth/solo-python/solo-python-0.0.27.ebuild b/sys-auth/solo-python/solo-python-0.0.27.ebuild
new file mode 100644
index 000000000000..29ea8a9393ae
--- /dev/null
+++ b/sys-auth/solo-python/solo-python-0.0.27.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool and library for SoloKeys"
+HOMEPAGE="https://github.com/solokeys/solo-python"
+SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/click-7.0.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.8.1[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # For some reason the version file gets omitted by src_install (a bug in pyproject2setuppy?),
+ # and in any case there is no advantage to using one once a specific version has been released.
+ sed -i -e "s/^__version__ = open(.\+$/__version__ = '${PV}'/" solo/__init__.py || die "Failed to set the version number"
+ distutils-r1_src_prepare
+}