summaryrefslogtreecommitdiff
path: root/sys-auth/solo-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sys-auth/solo-python
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sys-auth/solo-python')
-rw-r--r--sys-auth/solo-python/Manifest3
-rw-r--r--sys-auth/solo-python/metadata.xml17
-rw-r--r--sys-auth/solo-python/solo-python-0.0.26.ebuild34
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-auth/solo-python/Manifest b/sys-auth/solo-python/Manifest
new file mode 100644
index 000000000000..cc0f0827fc11
--- /dev/null
+++ b/sys-auth/solo-python/Manifest
@@ -0,0 +1,3 @@
+DIST solo-python-0.0.26.tar.gz 35251 BLAKE2B 76e515667220a8efdd16e159008eed8232721e0a8a1a1bffbc773cfa832b2f112d8dc229bf69dc4ccbee1d11b41d630a2d91e2383ebd19158d8c46ccf4f355de SHA512 f97da4a4ed3b0e0f4715407b179d8a8c1385076611fe8669cec6b514313d38dd14c6c22434b73e2c72f7456407a6c942b26b72cca7a56969cfbc630ee25aad85
+EBUILD solo-python-0.0.26.ebuild 1134 BLAKE2B ad413f62e3676e4983aac0c61cefa18c13e4bffdc54b211e2680fe6fc590d385c9e8b7d2965b6eb542e89dc4d8a376ca54ec40f73e6bc001a3273caea4cf9c28 SHA512 7f91aaeae79b0580602613847e9160929607ae605f4dacb531ef02855ed63eb9e3dc07349942b063f5534977cb9307ca1d99d428a9b38ed918300816a2210465
+MISC metadata.xml 667 BLAKE2B 7ca73329d8c7713c4c96848d6c5fc23bec99cd45e42266236fe2c5e7d70023bd8d5647da307f0e362863b38393fb9d66c2bb8965763eac3bdf7d5f30a357c7a0 SHA512 ec1899ba5d2082758c79a2abda4e834fbe31358c900507d02801b2a04ea8d37ca2d420a974e16fc8813ffc4f92488f8db5a0d998600c6d28191942592004d031
diff --git a/sys-auth/solo-python/metadata.xml b/sys-auth/solo-python/metadata.xml
new file mode 100644
index 000000000000..9014b8d50308
--- /dev/null
+++ b/sys-auth/solo-python/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ The command-line tool 'solo' provided by this package can be used to reset a SoloKey,
+ set/change the PIN, generate credentials, interact with the on-board TRNG, update
+ the firmware, and more. See the output of 'solo key --help' for more information.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">solokeys/solo-python</remote-id>
+ <remote-id type="pypi">solo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/solo-python/solo-python-0.0.26.ebuild b/sys-auth/solo-python/solo-python-0.0.26.ebuild
new file mode 100644
index 000000000000..a63f71dd2241
--- /dev/null
+++ b/sys-auth/solo-python/solo-python-0.0.26.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool and library for SoloKeys"
+HOMEPAGE="https://github.com/solokeys/solo-python"
+SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/click-7.0.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # For some reason the version file gets omitted by src_install (a bug in pyproject2setuppy?),
+ # and in any case there is no advantage to using one once a specific version has been released.
+ sed -i -e "s/^__version__ = open(.\+$/__version__ = '${PV}'/" solo/__init__.py || die "Failed to set the version number"
+ distutils-r1_src_prepare
+}