summaryrefslogtreecommitdiff
path: root/sys-auth/solo-python/solo-python-0.0.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /sys-auth/solo-python/solo-python-0.0.30.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'sys-auth/solo-python/solo-python-0.0.30.ebuild')
-rw-r--r--sys-auth/solo-python/solo-python-0.0.30.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/sys-auth/solo-python/solo-python-0.0.30.ebuild b/sys-auth/solo-python/solo-python-0.0.30.ebuild
deleted file mode 100644
index e8cd0529f6d9..000000000000
--- a/sys-auth/solo-python/solo-python-0.0.30.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-
-inherit distutils-r1
-
-DESCRIPTION="Python tool and library for SoloKeys"
-HOMEPAGE="https://github.com/solokeys/solo-python"
-SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv"
-
-RDEPEND=">=dev-python/click-7.1.0[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/ecdsa[${PYTHON_USEDEP}]
- >=dev-python/fido2-0.9.1[${PYTHON_USEDEP}]
- dev-python/intelhex[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- dev-python/pyusb[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]"
-
-src_prepare() {
- # For some reason the version file gets omitted by src_install (a bug in pyproject2setuppy?),
- # and in any case there is no advantage to using one once a specific version has been released.
- sed -i -e "s/^__version__ = open(.\+$/__version__ = '${PV}'/" solo/__init__.py || die "Failed to set the version number"
- distutils-r1_src_prepare
-}