summaryrefslogtreecommitdiff
path: root/sys-auth/skey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
commit48dbe17904ac8ee6f006488d8f21734b0d253db4 (patch)
tree90c7f087cbefd4ac6b893072d309e75dbf019f76 /sys-auth/skey
parent7972abc05090180dcc09d2b16af4020ce1cd1841 (diff)
gentoo auto-resync : 17:03:2023 - 00:25:50
Diffstat (limited to 'sys-auth/skey')
-rw-r--r--sys-auth/skey/Manifest2
-rw-r--r--sys-auth/skey/skey-1.1.5-r14.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/sys-auth/skey/Manifest b/sys-auth/skey/Manifest
index 13b247453f74..5189ce67b094 100644
--- a/sys-auth/skey/Manifest
+++ b/sys-auth/skey/Manifest
@@ -1,4 +1,6 @@
DIST skey-1.1.5-patches-6.tar.xz 34108 BLAKE2B 410dbe673e0a32a4c3fd0610f898057e7b3afcc0d0fd124683033790f9c518bf89486f13e8d87825c0959ff34e91eae82df6ba3b79c1dcb99a34d5657036d5a6 SHA512 2c807675cdd6b800f03427d79d616f59ac9d4d438221913328ec92e5dd13af185f74a24e17d36af8d49a51c4ecc5b24ef198489acce416d829e8aacf5d3c208a
+DIST skey-1.1.5-patches-7.tar.xz 34412 BLAKE2B 77c37b71e80a629dc24996a496ac870d8ad431268bc8eff188ffe09fda6c52b4169aae6e16d31897658e003c1565176f5b8bdd7052795b372c47e49258a7d8ff SHA512 a73f0772883cfb8a6cd7acabd0d005e723952c4eb3b83d27b5c321737e38a4b4b65be0e7cb1b4fb5d040e315b3c36f6f4ca96f20ad8564617e694e9373fa060d
DIST skey-1.1.5.tar.bz2 61911 BLAKE2B 6226a91f4018bee5796bf60339dc8554324a044eef18a69ea176d060cb4af90779cafaee58f42ad7a6e433b94da8de6e5e4d1ee9362904966fd0872d5ac3ccce SHA512 4cbddc7e31134d5e23801a9b07de0d05c8357aaa8dddfb8426fceead3f54e539f77204f78a08b2a93890ef2f4f807a2208080f58f80818afa1b8cd4884b1fb37
EBUILD skey-1.1.5-r13.ebuild 2139 BLAKE2B d890b62b8d5945078969b4e1e251792df7ed00a17f7a139421cf68c5aa0c9871ed3cf28774477237d7cc97338078a1dd8d5a7995ec62403798a6455472888be0 SHA512 63cbbbc3284077094e2e10a6a695d6ff4dd969879f3b5fb803316a279c6c329455ab62684ddbb38bc2e373667ee3eda1481161eb0e64f4f33b6d5285679e1cd7
+EBUILD skey-1.1.5-r14.ebuild 2146 BLAKE2B aea8aa6ba4f2815058303ff8d2af0b8eacdb693e4f65ec07dc0b6651140597e0e05d5e6f4f806b91f06ae93d70c27d78ed9d03efe8d86b8ea68855575e550bce SHA512 6d3f0f1f24998b79404e7b2494357f28670f918fcf2881a5e3b76f32fb270bd2d22c5fe1f8ef6aa12eb318e2eaacd207d497e04b4994d5cc8ffbae5a65531f2f
MISC metadata.xml 1433 BLAKE2B fd0468c647d2f1bf32f3de9c475ab7249abb0ff644b0eefa1e8d549388ccd816317f7e69788c7f8566094521b8716c3660a5edb2ff7177b82f7f54fecff09c91 SHA512 9823479c4d2213a47660f4d7119adcccc104d07144a4981f7f3a80260a14a3535d3dfe952ead65fd2ecd84cde45709006dee4e7d41cb6d5993ba3f25e0de3d4d
diff --git a/sys-auth/skey/skey-1.1.5-r14.ebuild b/sys-auth/skey/skey-1.1.5-r14.ebuild
new file mode 100644
index 000000000000..b003516a9db7
--- /dev/null
+++ b/sys-auth/skey/skey-1.1.5-r14.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1 toolchain-funcs usr-ldscript
+
+DESCRIPTION="Linux Port of OpenBSD Single-key Password System"
+HOMEPAGE="https://web.archive.org/web/20160710152027/http://www.openbsd.org:80/faq/faq8.html#SKey"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~ulm/distfiles/${P}-patches-7.tar.xz"
+
+LICENSE="BSD MIT RSA BEER-WARE"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-lang/perl
+ sys-libs/cracklib
+ virtual/libcrypt:="
+
+RDEPEND="${DEPEND}
+ virtual/perl-Time-Local"
+
+BDEPEND="app-arch/xz-utils"
+
+PATCHES=("${WORKDIR}/patch")
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf --sysconfdir=/etc/skey
+}
+
+src_install() {
+ into /
+ dolib.so libskey.so{.${PV},.${PV%.*},.${PV%%.*},}
+
+ into /usr
+ dobin skey skeyinit skeyinfo
+ newbin skeyaudit.sh skeyaudit
+ newsbin skeyprune.pl skeyprune
+
+ dosym skey /usr/bin/otp-md4
+ dosym skey /usr/bin/otp-md5
+ dosym skey /usr/bin/otp-sha1
+
+ if use static-libs; then
+ dolib.a libskey.a
+ gen_usr_ldscript libskey.so
+ fi
+
+ doman skey.1 skeyaudit.1 skeyinfo.1 skeyinit.1 skey.3 skeyprune.8
+
+ insinto /usr/include
+ doins skey.h
+
+ keepdir /etc/skey
+
+ # only root needs to have access to these files.
+ fperms go-rx /etc/skey
+
+ # skeyinit and skeyinfo must be suid root so users
+ # can generate their passwords.
+ fperms u+s,go-r /usr/bin/skeyinit /usr/bin/skeyinfo
+
+ dodoc README CHANGES
+
+ local DOC_CONTENTS="For an introduction into using s/key authentication,
+ take a look at the EXAMPLES section from the skey(1) manpage."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ # do not include /etc/skey/skeykeys in the package, as quickpkg
+ # may package sensitive information.
+ # This also fixes the etc-update issue with #64974.
+
+ # skeyinit will not function if this file is not present.
+ touch /etc/skey/skeykeys
+
+ # these permissions are applied by the skey system if missing.
+ chmod 0600 /etc/skey/skeykeys
+
+ readme.gentoo_print_elog
+}