summaryrefslogtreecommitdiff
path: root/sys-auth/passwdqc/passwdqc-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
commitd46d1d3a5897cade51811b3848c7bf27969da625 (patch)
tree0dabb04db53e3fe66abe43df0a3cdff5d3b664db /sys-auth/passwdqc/passwdqc-2.0.3.ebuild
parente67d5b4ba05349b3bf4229d0cf7d069809c4420e (diff)
gentoo auto-resync : 28:12:2023 - 07:37:55
Diffstat (limited to 'sys-auth/passwdqc/passwdqc-2.0.3.ebuild')
-rw-r--r--sys-auth/passwdqc/passwdqc-2.0.3.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/sys-auth/passwdqc/passwdqc-2.0.3.ebuild b/sys-auth/passwdqc/passwdqc-2.0.3.ebuild
deleted file mode 100644
index 1f921efc60bb..000000000000
--- a/sys-auth/passwdqc/passwdqc-2.0.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit pam toolchain-funcs
-
-DESCRIPTION="Password strength checking library (and PAM module)"
-HOMEPAGE="http://www.openwall.com/passwdqc/"
-SRC_URI="http://www.openwall.com/${PN}/${P}.tar.gz"
-
-LICENSE="Openwall BSD public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- sys-libs/pam
- virtual/libcrypt:=
-"
-DEPEND="${RDEPEND}"
-
-QA_FLAGS_IGNORED="
- lib*/security/pam_passwdqc.so
- usr/lib*/libpasswdqc.so.1
-"
-
-src_prepare() {
- default
-
- sed -i -e 's:`uname -s`:Linux:' Makefile || die
-
- # Ship our own default settings
- cat <<- EOF > "${S}/passwdqc.conf"
- min=disabled,24,11,8,7
- max=72
- passphrase=3
- match=4
- similar=deny
- random=47
- enforce=none
- retry=3
- EOF
-
-}
-
-_emake() {
- emake \
- SHARED_LIBDIR="/usr/$(get_libdir)" \
- SECUREDIR="$(getpam_mod_dir)" \
- CONFDIR="/etc/security" \
- CFLAGS="${CFLAGS} ${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- CC="$(tc-getCC)" \
- LD="$(tc-getCC)" \
- "$@"
-}
-
-src_compile() {
- _emake all
-}
-
-src_install() {
- _emake DESTDIR="${ED}" install_lib install_pam install_utils
- dodoc README PLATFORMS INTERNALS
-}