summaryrefslogtreecommitdiff
path: root/sys-auth/pambase/pambase-20140313.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /sys-auth/pambase/pambase-20140313.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'sys-auth/pambase/pambase-20140313.ebuild')
-rw-r--r--sys-auth/pambase/pambase-20140313.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/sys-auth/pambase/pambase-20140313.ebuild b/sys-auth/pambase/pambase-20140313.ebuild
deleted file mode 100644
index cc0940901457..000000000000
--- a/sys-auth/pambase/pambase-20140313.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils
-
-DESCRIPTION="PAM base configuration files"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:PAM"
-SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="consolekit +cracklib debug gnome-keyring minimal mktemp pam_krb5 pam_ssh passwdqc selinux +sha512 systemd"
-
-RESTRICT=binchecks
-
-MIN_PAM_REQ=1.1.3
-
-RDEPEND="
- || (
- >=sys-libs/pam-${MIN_PAM_REQ}
- ( sys-auth/openpam sys-freebsd/freebsd-pam-modules )
- )
- consolekit? ( >=sys-auth/consolekit-0.4.6[pam] )
- cracklib? ( >=sys-libs/pam-${MIN_PAM_REQ}[cracklib] )
- gnome-keyring? ( >=gnome-base/gnome-keyring-2.32[pam] )
- mktemp? ( sys-auth/pam_mktemp )
- pam_krb5? (
- || ( >=sys-libs/pam-${MIN_PAM_REQ} sys-auth/openpam )
- >=sys-auth/pam_krb5-4.3
- )
- pam_ssh? ( sys-auth/pam_ssh )
- passwdqc? ( >=sys-auth/pam_passwdqc-1.0.4 )
- selinux? ( >=sys-libs/pam-${MIN_PAM_REQ}[selinux] )
- sha512? ( >=sys-libs/pam-${MIN_PAM_REQ} )
- systemd? ( >=sys-apps/systemd-204[pam] )
- !<sys-apps/shadow-4.1.5-r1
- !<sys-freebsd/freebsd-pam-modules-6.2-r1
- !<sys-libs/pam-0.99.9.0-r1"
-DEPEND="app-portage/portage-utils"
-
-src_compile() {
- local implementation=
- local linux_pam_version=
- if has_version sys-libs/pam; then
- implementation=linux-pam
- local ver_str=$(qatom `best_version sys-libs/pam` | cut -d ' ' -f 3)
- linux_pam_version=$(printf "0x%02x%02x%02x" ${ver_str//\./ })
- elif has_version sys-auth/openpam; then
- implementation=openpam
- else
- die "PAM implementation not identified"
- fi
-
- use_var() {
- local varname=$(echo $1 | tr [a-z] [A-Z])
- local usename=${2-$(echo $1 | tr [A-Z] [a-z])}
- local varvalue=$(usex $usename)
- echo "${varname}=${varvalue}"
- }
-
- emake \
- GIT=true \
- $(use_var debug) \
- $(use_var cracklib) \
- $(use_var passwdqc) \
- $(use_var consolekit) \
- $(use_var systemd) \
- $(use_var GNOME_KEYRING gnome-keyring) \
- $(use_var selinux) \
- $(use_var mktemp) \
- $(use_var PAM_SSH pam_ssh) \
- $(use_var sha512) \
- $(use_var KRB5 pam_krb5) \
- $(use_var minimal) \
- IMPLEMENTATION=${implementation} \
- LINUX_PAM_VERSION=${linux_pam_version}
-}
-
-src_test() { :; }
-
-src_install() {
- emake GIT=true DESTDIR="${ED}" install
-}
-
-pkg_postinst() {
- if use systemd && use consolekit; then
- ewarn "You are enabling 2 session trackers, ConsoleKit and systemd-logind"
- ewarn "at the same time. This is not recommended setup to have, please"
- ewarn "consider disabling either USE=\"consolekit\" or USE=\"systemd\."
- fi
-}