summaryrefslogtreecommitdiff
path: root/sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild')
-rw-r--r--sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild b/sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild
new file mode 100644
index 000000000000..106358f09379
--- /dev/null
+++ b/sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit pam eutils toolchain-funcs
+
+DESCRIPTION="Password strength checking for PAM aware password changing programs"
+HOMEPAGE="http://www.openwall.com/passwdqc/"
+SRC_URI="http://www.openwall.com/pam/modules/pam_passwdqc/${P}.tar.gz"
+
+LICENSE="Openwall BSD public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+
+DEPEND="virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake \
+ OPTCFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ || die "emake failed"
+}
+
+src_install() {
+ dopammod pam_passwdqc.so
+
+ doman pam_passwdqc.8
+ dodoc README PLATFORMS INTERNALS
+}
+
+pkg_postinst() {
+ elog
+ elog "To activate pam_passwdqc use pam_passwdqc.so instead"
+ elog "of pam_cracklib.so in /etc/pam.d/system-auth."
+ elog "Also, if you want to change the parameters, read up"
+ elog "on the pam_passwdqc(8) man page."
+ elog
+}