summaryrefslogtreecommitdiff
path: root/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild')
-rw-r--r--sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild b/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
new file mode 100644
index 000000000000..0c1a0b837148
--- /dev/null
+++ b/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="libnss-cache is a library that serves nss lookups"
+HOMEPAGE="https://github.com/google/nsscache"
+SRC_URI="https://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="multilib"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.10.1-make.patch
+ epatch "${FILESDIR}"/${PN}-0.10-fix-shadow-test.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" nss_cache || die
+ if use multilib && has_multilib_profile; then
+ emake CC="$(tc-getCC)" nss_cache32 || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die
+ if use multilib && has_multilib_profile; then
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install32 || die
+ fi
+}