summaryrefslogtreecommitdiff
path: root/sys-auth/fprintd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sys-auth/fprintd/files
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sys-auth/fprintd/files')
-rw-r--r--sys-auth/fprintd/files/fprintd-0.8.1-fno-common.patch44
-rw-r--r--sys-auth/fprintd/files/fprintd-1.90.7_0001-add-test-feature-and-make-tests-optional.patch75
-rw-r--r--sys-auth/fprintd/files/fprintd-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch24
3 files changed, 143 insertions, 0 deletions
diff --git a/sys-auth/fprintd/files/fprintd-0.8.1-fno-common.patch b/sys-auth/fprintd/files/fprintd-0.8.1-fno-common.patch
new file mode 100644
index 000000000000..ba4574fce60d
--- /dev/null
+++ b/sys-auth/fprintd/files/fprintd-0.8.1-fno-common.patch
@@ -0,0 +1,44 @@
+--- a/src/device.c
++++ b/src/device.c
+@@ -47,6 +47,7 @@ static char *fingers[] = {
+ "right-little-finger"
+ };
+
++extern struct storage store;
+ extern DBusGConnection *fprintd_dbus_conn;
+
+ static void fprint_device_claim(FprintDevice *rdev,
+--- a/src/file_storage.c
++++ b/src/file_storage.c
+@@ -44,6 +44,7 @@
+ #define FP_FINGER_IS_VALID(finger) \
+ ((finger) >= LEFT_THUMB && (finger) <= RIGHT_LITTLE)
+
++extern struct storage store;
+ static char *get_path_to_storedir(uint16_t driver_id, uint32_t devtype, char *base_store)
+ {
+ char idstr[5];
+--- a/src/main.c
++++ b/src/main.c
+@@ -34,6 +34,7 @@
+ #include "storage.h"
+ #include "file_storage.h"
+
++struct storage store;
+ extern DBusGConnection *fprintd_dbus_conn;
+ static gboolean no_timeout = FALSE;
+ static gboolean g_fatal_warnings = FALSE;
+--- a/src/storage.h
++++ b/src/storage.h
+@@ -41,10 +41,7 @@ struct storage {
+ storage_discover_prints discover_prints;
+ };
+
+-typedef struct storage fp_storage;
+-
+-/* The currently setup store */
+-fp_storage store;
++extern struct storage store;
+
+ #endif
+
diff --git a/sys-auth/fprintd/files/fprintd-1.90.7_0001-add-test-feature-and-make-tests-optional.patch b/sys-auth/fprintd/files/fprintd-1.90.7_0001-add-test-feature-and-make-tests-optional.patch
new file mode 100644
index 000000000000..95428184c2f5
--- /dev/null
+++ b/sys-auth/fprintd/files/fprintd-1.90.7_0001-add-test-feature-and-make-tests-optional.patch
@@ -0,0 +1,75 @@
+From 7820465f078e9655af70036d8c570fd644b38f22 Mon Sep 17 00:00:00 2001
+From: Martin Gysel <me@bearsh.org>
+Date: Thu, 19 Nov 2020 07:04:10 +0100
+Subject: [PATCH 1/2] add test feature and make tests optional
+
+---
+ meson.build | 14 ++++++++++----
+ meson_options.txt | 4 ++++
+ 2 files changed, 14 insertions(+), 4 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 66aa2f7..ba44788 100644
+--- a/meson.build
++++ b/meson.build
+@@ -125,7 +125,7 @@ endif
+ polkit_policy_directory = polkit_gobject_dep.get_pkgconfig_variable('policydir')
+
+ # Tests dependencies
+-pam_wrapper_dep = dependency('pam_wrapper', required: get_option('pam'))
++pam_wrapper_dep = dependency('pam_wrapper', required: get_option('pam') and get_option('test').enabled() )
+
+ xmllint = find_program('xmllint', required: false)
+ python3 = find_program('python3') # No meson without it!
+@@ -139,11 +139,13 @@ python3_test_modules = {
+ }
+ python3_available_modules = []
+
++if get_option('test').enabled()
+ foreach module, required : python3_test_modules
+ if required and run_command(python3, '-c', 'import @0@'.format(module)).returncode() != 0
+ error('Python3 module \'' + module + '\' required by test suite not found')
+ endif
+ endforeach
++endif
+
+ cdata = configuration_data()
+ cdata.set_quoted('GETTEXT_PACKAGE', meson.project_name())
+@@ -167,7 +169,9 @@ endif
+ if get_option('gtk_doc')
+ subdir('doc')
+ endif
+-subdir('tests')
++if get_option('test').enabled()
++ subdir('tests')
++endif
+ subdir('po')
+
+ output = []
+@@ -189,7 +193,9 @@ output += ' PAM module: ' + pam_dep.found().to_string()
+ output += ' Manuals: ' + get_option('man').to_string()
+ output += ' GTK Doc: ' + get_option('gtk_doc').to_string()
+ output += ' XML Linter ' + xmllint.found().to_string()
+-output += '\nTest setup:\n'
+-output += ' With address sanitizer: ' + address_sanitizer.to_string()
++if get_option('test').enabled()
++ output += '\nTest setup:\n'
++ output += ' With address sanitizer: ' + address_sanitizer.to_string()
++endif
+
+ message('\n'+'\n'.join(output)+'\n')
+diff --git a/meson_options.txt b/meson_options.txt
+index be31fe1..92c01cd 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -19,3 +19,7 @@ option('gtk_doc',
+ type: 'boolean',
+ value: false,
+ description: 'Use gtk-doc to build documentation')
++option('test',
++ type: 'feature',
++ value: 'disabled',
++ description: 'Enable tests')
+--
+2.29.2
+
diff --git a/sys-auth/fprintd/files/fprintd-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch b/sys-auth/fprintd/files/fprintd-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch
new file mode 100644
index 000000000000..a10026f33466
--- /dev/null
+++ b/sys-auth/fprintd/files/fprintd-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch
@@ -0,0 +1,24 @@
+--- fprintd-v1.90.8/meson.build.orig 2020-12-13 08:08:13.886367478 +0100
++++ fprintd-v1.90.8/meson.build 2020-12-13 08:30:16.056756878 +0100
+@@ -84,7 +84,7 @@
+ libfprint_dep = dependency('libfprint-2', version: '>=' + libfprint_min_version)
+ polkit_gobject_dep = dependency('polkit-gobject-1', version: '>= 0.91')
+ dbus_dep = dependency('dbus-1', required: false)
+-libsystemd_dep = dependency('libsystemd', required: get_option('pam'))
++libsystemd_dep = dependency(get_option('libsystemd'), required: get_option('pam'))
+ pam_dep = cc.find_library('pam',
+ required: get_option('pam'),
+ has_headers: 'security/pam_modules.h',
+--- fprintd-v1.90.8/meson_options.txt.orig 2020-12-13 08:08:13.886367478 +0100
++++ fprintd-v1.90.8/meson_options.txt 2020-12-13 08:26:57.111919403 +0100
+@@ -10,6 +10,10 @@
+ description: 'Install system service files',
+ type: 'boolean',
+ value: true)
++option('libsystemd',
++ description: 'Libsystemd provider (libsystemd or libelogind)',
++ type: 'string',
++ value: 'libsystemd')
+ option('systemd_system_unit_dir',
+ description: 'Directory for systemd service files',
+ type: 'string')