summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-05 03:04:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-05 03:04:53 +0000
commit94393d04ccce851b0084c650c99a2eca52f9d3bb (patch)
tree1da77141f18141b486ecd360d46c5988962c7653 /sys-apps
parentc4d92ab721dfc646b4a58429d965e9446294ce26 (diff)
gentoo auto-resync : 05:12:2022 - 03:04:53
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin49293 -> 49296 bytes
-rw-r--r--sys-apps/grep/Manifest3
-rw-r--r--sys-apps/grep/grep-3.8-r1.ebuild100
-rw-r--r--sys-apps/grep/metadata.xml12
-rw-r--r--sys-apps/portage/Manifest2
-rw-r--r--sys-apps/portage/portage-3.0.41.ebuild283
6 files changed, 399 insertions, 1 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index f47a5b31fd77..fbc491724987 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/grep/Manifest b/sys-apps/grep/Manifest
index 8b0b46c0b29a..8283ea443ece 100644
--- a/sys-apps/grep/Manifest
+++ b/sys-apps/grep/Manifest
@@ -5,5 +5,6 @@ DIST grep-3.7.tar.xz.sig 833 BLAKE2B 02a2850e22e8054dcfd02b6f08747a97d43dae9adb9
DIST grep-3.8.tar.xz 1709536 BLAKE2B 24cf6f7aa35c85f59f508969ee9731c5be1e5c613e64e636f464bbdde917bb99ba739e4b82abf08da127ad0400d62e27d139f85142035745121d381982ec6c36 SHA512 2014519a80c6dcd799837e1bd7d9d5ebe8729ec54b0dc76981dac4755a9a8a9f200470cdcc911e2825bed8162e61da39e3dd60289f7393b48bf67314077d0c79
DIST grep-3.8.tar.xz.sig 833 BLAKE2B 40f472389705375611015ba0eb85eb32643304b1a324877a75821d086a128a20d00df3d7cd960ec45709f40f21488bbcf993c6fe667ef23663688b33296e650b SHA512 8266b58485f225c2189814e3898c72e59d251b729e0c302d31f57abdb7ac2e6e28dde2c5c8095673b6f007b2a3ebc26db1dca910a7771aba80dad4b3c6761ee4
EBUILD grep-3.7.ebuild 2274 BLAKE2B b847a17bfe835e573a6406c728e99c1af5687bc2e83bdb4c1b6103790f587210c5bd3f4121c7fb83d8c96805a6a7fc636f06050df1f8f591d95e931f2cfecbc9 SHA512 dace79b242b68187cf8d756b4c91a7873eb8c1b1a3f631b67bb07192a95c4c4af521db19e6a943ae03f1d885317c0d6f497e129c7644e36d5dc97963415396ee
+EBUILD grep-3.8-r1.ebuild 2870 BLAKE2B ef19db94761e3e8fcfd6bdd03429bdd16501cf4724597f0aabff96f4f1d1712a3307ee6b87e9888e0f73de1f2d1ba31769211412aeb42687f24bd3fd8474861d SHA512 3e63dc69b45d4903241cc54ea5efbad05db1d6f7874671c803007e728932aa18472bb777be830ddba4ee5e47ef60f0f01972f2339fb89136f90960d118b39158
EBUILD grep-3.8.ebuild 2168 BLAKE2B 0b2a09225597916015eab1a036aec94af8fbbd80e61010262cb1eff62fa10ada13e22fba7f7e1192d904b80817e34ecb61b30dede0aab4d615b2bf7d8b94fc59 SHA512 c1c3228795c6cc2d3f07f75c49d5e5834b08d8340420450ef380c99ef9275cc7ee8de4ada5fee83f11cca6abe364f5a6083531d9db6fe8da9c5977cf40e4566f
-MISC metadata.xml 335 BLAKE2B 9348d579c8858b0764c9e6edc144183686945cac2a68eead6e5ad83d364d293292ec6ef97bf87ea5c146048757d080e157bf9edf101177a8854d77305d8a9dae SHA512 3ea8b4569cfadab59ecabcf13c25941f9ad0db6c15b0625760339224aa4c82dc99b102c59c858de20d3ab9399db38f47e23d1b360ff86cfba6ede73b548ea7ff
+MISC metadata.xml 666 BLAKE2B 0c90e38d5363234474093ece5c9e0cbb99c01731a80c52869d700b7367fd74eec23f355653174b315f91ca7b41b4c5c9f5645ffaba043b3918c3c22c2c817ea4 SHA512 8e46c5c28b55063a7c74dfc637eb59785dc35651027e144acf4aea7f0ad7a4e43a3692946252acdf0d4a66ff8bdcfa89664fdf8bae71f1db688c06014c2a6a0f
diff --git a/sys-apps/grep/grep-3.8-r1.ebuild b/sys-apps/grep/grep-3.8-r1.ebuild
new file mode 100644
index 000000000000..383ac1eb28d7
--- /dev/null
+++ b/sys-apps/grep/grep-3.8-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/grep.asc
+inherit flag-o-matic verify-sig
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="https://www.gnu.org/software/grep/"
+
+if [[ ${PV} == *_p* ]] ; then
+ # Subscribe to the 'platform-testers' ML to find these.
+ # Useful to test on our especially more niche arches and report issues upstream.
+ MY_COMMIT="98-c9ac"
+ MY_P=${PN}-$(ver_cut 1-2).${MY_COMMIT}
+ SRC_URI="https://meyering.net/${PN}/${MY_P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://meyering.net/${PN}/${MY_P}.tar.xz.sig )"
+ S="${WORKDIR}"/${MY_P}
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+egrep-fgrep nls pcre static"
+
+# We lack dev-libs/libsigsegv[static-libs] for now
+REQUIRED_USE="static? ( !sparc )"
+
+LIB_DEPEND="pcre? ( >=dev-libs/libpcre2-7.8-r1[static-libs(+)] )
+ sparc? ( dev-libs/libsigsegv )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-grep )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ default
+
+ # bug #523898
+ sed -i \
+ -e "s:@SHELL@:${EPREFIX}/bin/sh:g" \
+ -e "s:@grep@:${EPREFIX}/bin/grep:" \
+ src/egrep.sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # We used to turn this off unconditionally (bug #673524) but we now
+ # allow it for cases where libsigsegv is better for userspace handling
+ # of stack overflows.
+ # In particular, it's necessary for sparc: bug #768135
+ export ac_cv_libsigsegv=$(usex sparc)
+
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ $(use_enable nls)
+ $(use_enable pcre perl-regexp)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use egrep-fgrep ; then
+ # Delete the upstream wrapper variants which warn on egrep+fgrep use
+ rm "${ED}"/bin/{egrep,fgrep} || die
+
+ into /
+ # Install egrep, fgrep which don't warn.
+ #
+ # We do this by default to avoid breakage in old scripts
+ # and such which don't expect unexpected output on stderr,
+ # we've had examples of builds failing because foo-config
+ # starts returning a warning.
+ #
+ # https://lists.gnu.org/archive/html/bug-grep/2022-10/msg00000.html
+ newbin - egrep <<-EOF
+ #!/usr/bin/env sh
+ exec "${EPREFIX}/bin/grep" -E "\$@"
+ EOF
+
+ newbin - fgrep <<-EOF
+ #!/usr/bin/env sh
+ exec "${EPREFIX}/bin/grep" -F "\$@"
+ EOF
+ fi
+}
diff --git a/sys-apps/grep/metadata.xml b/sys-apps/grep/metadata.xml
index 3c76c298887a..89eff5cf9f7e 100644
--- a/sys-apps/grep/metadata.xml
+++ b/sys-apps/grep/metadata.xml
@@ -5,6 +5,18 @@
<email>base-system@gentoo.org</email>
<name>Gentoo Base System</name>
</maintainer>
+ <use>
+ <flag name="egrep-fgrep">
+ Install deprecated 'egrep' and 'fgrep' wrappers
+ for 'grep -E' and 'grep -F' respectively.
+
+ GNU grep 3.8 onwards warns about their usage by
+ default, but the versions installed by this flag do not.
+
+ No deprecation warnings are emitted when this
+ flag is enabled.
+ </flag>
+ </use>
<upstream>
<remote-id type="cpe">cpe:/a:gnu:grep</remote-id>
</upstream>
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index e362faff354d..b4bb7358b446 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -7,8 +7,10 @@ AUX portage-tmpdir.conf 76 BLAKE2B 79f35df57dbdcd461d94d558212261df7df54253d5205
DIST portage-3.0.38.1.tar.bz2 1116216 BLAKE2B d1cb4cc1924673d07ea7174ad0a84b3af977dd28ca659695d3e4014e4aa83b054acba82a160e7c0a8d3d4fbc3514bea619c3d720e450cb4890818e4b1bc1e43a SHA512 1375565e936276fd6cfd2a4f6f782b91e234e973d6a998f2276a076dd165272bcf12067fd01e77b238f194eac69edf967bbe3ac62edc3701fe9375c693622ab9
DIST portage-3.0.39.tar.bz2 1118397 BLAKE2B bd0105c48741cdf11166208ebf11f524cb87980a027b69ccdcc2a607847dcd79d886b542adf08eefdd2df8a35e78f95f0f79843694ec9c2b1488d7ee1fd187e8 SHA512 e3ef14136b0ffb5f77fed9cb89ce6ee59425dd34acc5254390e75164aee160e954498bca4084f3d71642f285ba040ce8347badf6382dd1369aa52425ce907e39
DIST portage-3.0.40.tar.bz2 1119105 BLAKE2B 64be77aaf280008829847e6c78f1d0e1b74af4e5835ced96b0d146fef81c6c8c49e70e92ebb9bc1805f1853dbed4ada4b9fc6282b7b04478fe0fadec7b93784e SHA512 fd2e858788e41ea7f9201d77e056a71d6bd2a450be9896d9e10ad731f7d88b8bb1c69fd7b9bea3ab831fb352e0ce6df39f97786d067244794254996f6927a455
+DIST portage-3.0.41.tar.bz2 1119737 BLAKE2B 6c6d1fa11f16362505e321eb530d233cf73a7e1cc7dab2fc88ad40701c16835e08a7d16a408381e2f717ac5f48d46344e57b9b5296be4eba0a7583540c6a81aa SHA512 046621ee59b2b1b374a63091028ed3462b1212960b337e8e034c739d5c51d5ae1e7b491c88940199e710081409e38778749a5c86576cf5bb6c59b1890dc892b5
EBUILD portage-3.0.38.1-r4.ebuild 9166 BLAKE2B a16bc125979b171a567935314d6895c371fa90394e7366dc4af678541817cdd8cd44ac1d30005953298b936db059fe226b47678d5cb0eb2610c0e871a39204b1 SHA512 bd647fbe3f7255de375a36b5bc843113fcf1505de5d9851b088546c94ca85d369e84647af7d8eb3115e5c0fab61616ab0aff6fb3d5691bc1d1ac20c4f0a61e23
EBUILD portage-3.0.39-r3.ebuild 9248 BLAKE2B d6e927109c445a6bc80497b3c52ff8ae88fbe1444aca9bccefe6ae2ca05095eecb15a356ad0bb70cc21f0dbe9c4943b721a33062d4b2a3f837ca6bb08dfd3d98 SHA512 a5e18930944135784142371728e190c11a760dc37f61a77bc92295e813a7ce691cffdde1dd605a2b8ab7f745de45813278aa0672aa944f2b64e1a24a26939c11
EBUILD portage-3.0.40.ebuild 9137 BLAKE2B 3614d94ce8acdb4ad42ca0445a8dad5991c563d316aee5b055d086f5aba7816d1a96144c667db7b3b644f9f474efe42e350151db808d67a942f973e54182e75d SHA512 bbc8d67eeccdb41a31be81c76643679b3131da2fd70c43ed22a007ca5ddfdff04ee3ac60fd9f702ed41f54f05f52e450c095b205279ad168602f6e3bb97e1983
+EBUILD portage-3.0.41.ebuild 9137 BLAKE2B 3614d94ce8acdb4ad42ca0445a8dad5991c563d316aee5b055d086f5aba7816d1a96144c667db7b3b644f9f474efe42e350151db808d67a942f973e54182e75d SHA512 bbc8d67eeccdb41a31be81c76643679b3131da2fd70c43ed22a007ca5ddfdff04ee3ac60fd9f702ed41f54f05f52e450c095b205279ad168602f6e3bb97e1983
EBUILD portage-9999.ebuild 8377 BLAKE2B 11d2bb192cd0fb41b528f7b7fa734aa91432d3a3dd51a28d8d1ab4c9f4d677e2f6ebc3caa0dce66651ce73c1d4a9a6cb5210cd7e392c88817fa2b55db12d492a SHA512 71551c10785fe35c4856e4d33343e59a663e16ff1d1d0bdcbaed58be4dd083e51a63b142fb7d17ace1ca9bd9b307a8597c5a3d0344693555cfa784d68fee91ec
MISC metadata.xml 1487 BLAKE2B 5b9833e8bfc2c38e4db95f2368a65d85623aa8dd166e4e09bed4cbe3a7e59d47da69a9dff1e6615fd64f349cc05f57217ee61ebfd23e3e13622a7573ea135659 SHA512 b22f8c1f3a4dce636d0f823f1303f60d32fd570b484e93a64dfbdcbe145534b3472ae94c1ac992a478c9e2930fbc8a5311e0080b4722f9b5dc29dff59ddaa7c8
diff --git a/sys-apps/portage/portage-3.0.41.ebuild b/sys-apps/portage/portage-3.0.41.ebuild
new file mode 100644
index 000000000000..89c318fe02f9
--- /dev/null
+++ b/sys-apps/portage/portage-3.0.41.ebuild
@@ -0,0 +1,283 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_REQ_USE='bzip2(+),threads(+)'
+TMPFILES_OPTIONAL=1
+
+inherit distutils-r1 linux-info toolchain-funcs tmpfiles prefix
+
+DESCRIPTION="The package management and distribution system for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+SRC_URI="https://gitweb.gentoo.org/proj/portage.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux test xattr"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/xz-utils
+ test? ( dev-vcs/git )"
+DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ >=sys-apps/sed-4.0.5 sys-devel/patch
+ doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
+ apidoc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-epytext[${PYTHON_USEDEP}]
+ )"
+# Require sandbox-2.2 for bug #288863.
+# For whirlpool hash, require python[ssl] (bug #425046).
+# For compgen, require bash[readline] (bug #445576).
+# app-portage/gemato goes without PYTHON_USEDEP since we're calling
+# the executable.
+RDEPEND="
+ acct-user/portage
+ app-arch/zstd
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ >=sys-apps/findutils-4.4
+ !build? (
+ >=sys-apps/sed-4.0.5
+ >=app-shells/bash-5.0:0[readline]
+ >=app-admin/eselect-1.2
+ rsync-verify? (
+ >=app-portage/gemato-14.5[${PYTHON_USEDEP}]
+ >=sec-keys/openpgp-keys-gentoo-release-20180706
+ >=app-crypt/gnupg-2.2.4-r2[ssl(-)]
+ )
+ )
+ elibc_glibc? ( >=sys-apps/sandbox-2.2 )
+ elibc_musl? ( >=sys-apps/sandbox-2.2 )
+ kernel_linux? ( sys-apps/util-linux )
+ >=app-misc/pax-utils-0.1.17
+ selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+ xattr? ( kernel_linux? (
+ >=sys-apps/install-xattr-0.3
+ ) )
+ !<app-admin/logrotate-3.8.0
+ !<app-portage/gentoolkit-0.4.6
+ !<app-portage/repoman-2.3.10
+ !~app-portage/repoman-3.0.0"
+PDEPEND="
+ !build? (
+ >=net-misc/rsync-2.6.4
+ >=sys-apps/file-5.41
+ >=sys-apps/coreutils-6.4
+ )"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# NOTE: FEATURES=installsources requires debugedit and rsync
+
+pkg_pretend() {
+ local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
+
+ if use native-extensions && tc-is-cross-compiler; then
+ einfo "Disabling USE=native-extensions for cross-compilation (bug #612158)"
+ fi
+
+ check_extra_config
+}
+
+python_prepare_all() {
+ local PATCHES=(
+ )
+
+ distutils-r1_python_prepare_all
+
+ sed -e "s:^VERSION = \"HEAD\"$:VERSION = \"${PV}\":" -i lib/portage/__init__.py || die
+
+ if use gentoo-dev; then
+ einfo "Disabling --dynamic-deps by default for gentoo-dev..."
+ sed -e 's:\("--dynamic-deps", \)\("y"\):\1"n":' \
+ -i lib/_emerge/create_depgraph_params.py || \
+ die "failed to patch create_depgraph_params.py"
+
+ einfo "Enabling additional FEATURES for gentoo-dev..."
+ echo 'FEATURES="${FEATURES} ipc-sandbox network-sandbox strict-keepdir"' \
+ >> cnf/make.globals || die
+ fi
+
+ if use native-extensions && ! tc-is-cross-compiler; then
+ printf "[build_ext]\nportage_ext_modules=true\n" >> \
+ setup.cfg || die
+ fi
+
+ if ! use ipc ; then
+ einfo "Disabling ipc..."
+ sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
+ -i lib/_emerge/AbstractEbuildProcess.py || \
+ die "failed to patch AbstractEbuildProcess.py"
+ fi
+
+ if use xattr && use kernel_linux ; then
+ einfo "Adding FEATURES=xattr to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
+ if use build || ! use rsync-verify; then
+ sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
+ -e '/^sync-webrsync-verify-signature/s|yes|no|' \
+ -i cnf/repos.conf || die "sed failed"
+ fi
+
+ if [[ -n ${EPREFIX} ]] ; then
+ einfo "Setting portage.const.EPREFIX ..."
+ hprefixify -e "s|^(EPREFIX[[:space:]]*=[[:space:]]*\").*|\1${EPREFIX}\"|" \
+ -w "/_BINARY/" lib/portage/const.py
+
+ einfo "Prefixing shebangs ..."
+ > "${T}/shebangs" || die
+ while read -r -d $'\0' ; do
+ local shebang=$(head -n1 "$REPLY")
+ if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
+ echo "${REPLY}" >> "${T}/shebangs" || die
+ fi
+ done < <(find . -type f -executable ! -name etc-update -print0)
+
+ if [[ -s ${T}/shebangs ]]; then
+ xargs sed -i -e "1s:^#!:#!${EPREFIX}:" < "${T}/shebangs" || die "sed failed"
+ fi
+
+ einfo "Adjusting make.globals, repos.conf and etc-update ..."
+ hprefixify cnf/{make.globals,repos.conf} bin/etc-update
+
+ if use prefix-guest ; then
+ sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
+ -e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
+ -e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
+ -i cnf/repos.conf || die "sed failed"
+ fi
+
+ einfo "Adding FEATURES=force-prefix to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
+ cd "${S}/cnf" || die
+ if [ -f "make.conf.example.${ARCH}".diff ]; then
+ patch make.conf.example "make.conf.example.${ARCH}".diff || \
+ die "Failed to patch make.conf.example"
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ fi
+}
+
+python_compile_all() {
+ local targets=()
+ use doc && targets+=( docbook )
+ use apidoc && targets+=( apidoc )
+
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local targets=()
+ use doc && targets+=(
+ install_docbook
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ use apidoc && targets+=(
+ install_apidoc
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+
+ # install docs
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+
+ dotmpfiles "${FILESDIR}"/portage-{ccache,tmpdir}.conf
+
+ # Due to distutils/python-exec limitations
+ # these must be installed to /usr/bin.
+ local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
+ einfo "Moving admin scripts to the correct directory"
+ dodir /usr/sbin
+ for target in ${sbin_relocations}; do
+ einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
+ mv "${ED}/usr/bin/${target}" "${ED}/usr/sbin/${target}" || die "sbin scripts move failed!"
+ done
+}
+
+pkg_preinst() {
+ if ! use build; then
+ python_setup
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ env -u DISTDIR \
+ -u PORTAGE_OVERRIDE_EPREFIX \
+ -u PORTAGE_REPOSITORIES \
+ -u PORTDIR \
+ -u PORTDIR_OVERLAY \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.default_locations || die
+
+ env -u BINPKG_COMPRESS -u PORTAGE_REPOSITORIES \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.binpkg_compression || die
+
+ env -u FEATURES -u PORTAGE_REPOSITORIES \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.binpkg_multi_instance || die
+ fi
+
+ # elog dir must exist to avoid logrotate error for bug #415911.
+ # This code runs in preinst in order to bypass the mapping of
+ # portage:portage to root:root which happens after src_install.
+ keepdir /var/log/portage/elog
+ # This is allowed to fail if the user/group are invalid for prefix users.
+ if chown portage:portage "${ED}"/var/log/portage{,/elog} 2>/dev/null ; then
+ chmod g+s,ug+rwx "${ED}"/var/log/portage{,/elog}
+ fi
+
+ if has_version "<${CATEGORY}/${PN}-2.3.77"; then
+ elog "The emerge --autounmask option is now disabled by default, except for"
+ elog "portions of behavior which are controlled by the --autounmask-use and"
+ elog "--autounmask-license options. For backward compatibility, previous"
+ elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
+ elog "Users can get the old behavior simply by adding --autounmask to the"
+ elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
+ elog "change, see https://bugs.gentoo.org/658648."
+ fi
+}
+
+pkg_postinst() {
+ # Warn about obsolete "enotice" script, bug #867010
+ local bashrc=${EROOT}/etc/portage/profile/profile.bashrc
+ if [[ -e ${bashrc} ]] && grep -q enotice "${bashrc}"; then
+ eerror "Obsolete 'enotice' script detected!"
+ eerror "Please remove this from ${bashrc} to avoid problems."
+ eerror "See bug 867010 for more details."
+ fi
+}