summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal-gnome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-apps/xdg-desktop-portal-gnome
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gnome')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/Manifest3
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/metadata.xml8
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.1.ebuild41
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/Manifest b/sys-apps/xdg-desktop-portal-gnome/Manifest
new file mode 100644
index 000000000000..5e37a7aa6299
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/Manifest
@@ -0,0 +1,3 @@
+DIST xdg-desktop-portal-gnome-42.1.tar.xz 117932 BLAKE2B c0c6dc7e4efbfda8996d63c191228ebf867e3fe11a0ae031b5bfd4298a33ab3b9cb9d9cecc36c1b41eeb33c54bd3bca17149e641c1131f0be7dcb2dbdf42eda8 SHA512 6843fd10e7e70f3d09c2a9b1397288f553fb44bcae30e7992790fddbc92d6c5cc966c27b7f294e2de1a139d3893c009f1480855d66c873a13861f3fe4abecee7
+EBUILD xdg-desktop-portal-gnome-42.1.ebuild 792 BLAKE2B e7ac062dc0ef3d32285f761ce0a2665914cc714549f9b80abed1bebc59fd6caba636000a8f6e399376d29a91bd7e4ca2eb680deb2d59904f9561ab40222dc1c7 SHA512 38cd1adc6b676a265f9c1dc9d255a0cfe6dc3e4402453e54d40d0e7cf7c4a50d285bc7fe81b8cc1ac0c65e2b50dbbc538ac503457c7a04391531297c1acab9b1
+MISC metadata.xml 254 BLAKE2B de7a97001e5947704f42973c8a0c3a23c2d80afb976254f5fd21e9d372a946e055d4cdc3c0eaed010505f87929b56e8b1e650c945e2a302644adbc9440833be8 SHA512 c81da4f9b80e5691a167f4590906952e25356604ec17689c005be14efb394c0634776bbe84df936edde239480bdf46db41216b00da4a3a45f670e9ca18ab0132
diff --git a/sys-apps/xdg-desktop-portal-gnome/metadata.xml b/sys-apps/xdg-desktop-portal-gnome/metadata.xml
new file mode 100644
index 000000000000..f453528b934f
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.1.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.1.ebuild
new file mode 100644
index 000000000000..06373774a4c6
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.7
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}